MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Back to Booting to black

  • Re: MM booting to black

    Well, all was going pretty good. I added some modules and removed some. Had Carousel, NHL and NFL working well. Almost.
    Then I changed the Calendar to another module, didn’t like the look so went back to calendar and everything went into the toilet. It was booting to black so I went back into it from my laptop and checked the config.js file and could not find an error. Copied it to Jshint and it gave this:
    One undefined variable
    111 module
    That was in the last line:
    /*************** DO NOT EDIT THE LINE BELOW ***************/
    if (typeof module !== “undefined”) {module.exports = config;}
    But that is the same in the sample and my backup.
    So I deleted the config.js and renamed the backup as config.js. No change.
    I stopped the process with:
    pm2 stop all and got:
    │ Name │ mode │ status │ ↺ │ cpu │ memory │
    │ MagicMirror │ fork │ stopped │ 0 │ 0% │ 0 B │

    I ran npm config:check and got:
    pi@raspberrypi:~/MagicMirror/config $ npm run config:check

    magicmirror@2.6.0 config:check /home/pi/MagicMirror
    node tests/configs/check_config.js

    Checking file… /home/pi/MagicMirror/config/config.js
    Your configuration file doesn’t contain syntax errors 🙂

    So now I am not sure which direction to go.

  • start the MM in debug mode

    npm start dev

    then select the console tab… look for errors (red text)

    altho usually black screen is caused by failures in the node modules

    so, minimze MM, alt-spacebar, n
    and look at errors in the console window (used above for npm start

  • @sdetweil

    pi@raspberrypi:~ $ npm start dev
    npm ERR! missing script: start

    That’s what I got.

  • @dwleo well, you have to be IN the MM folder

    cd MagicMirror

  • @sdetweil
    WARNING! Could not load config file. Starting with default configuration. Error found: Error: Cannot find module ‘moment-timezone’

  • Sometimes I feel like a real noob. Anyway the config.js file is there right where it always has been.

  • @dwleo

    from the MM folder run

    node tests/configs/check_config.js

    and work thru the errors from top to bottom

    rerunning as needed

  • @dwleo yes, but there is a syntax error from all the editing you have done

    make a rule,

    1 change at a time,
    AND save the working config.js before u edit

  • @sdetweil
    Yeah, you are right. (sigh)
    Anyway I ran it and got this:
    pi@raspberrypi:~/MagicMirror $ node tests/configs/check_config.js
    Checking file… /home/pi/MagicMirror/config/config.js
    Your configuration file doesn’t contain syntax errors 🙂

  • @dwleo ok, then you have a module name wrong, or u deleted it

    Cannot find module ‘moment-timezone’

    OR, you installed a module, but didn’t finish ITS install, by going to ITS folder and running npm install

    when a module uses other modules, (some not used by base MM), you have to do a manual step to install ITS dependencies

    so, I would look thru the modules u might have just installed, and edit the package.json file in each and look for moment-timezone… if its there, then u probably need to run npm install in that folder

Log in to reply