Dependency Problems



  • When running npm install on my raspberry pi 2, I encounter this error:
    /

    magicmirror@2.0.0 prepublish /home/pi/MagicMirror
    npm run snyk-protect

    magicmirror@2.0.0 snyk-protect /home/pi/MagicMirror
    snyk protect

    Successfully applied Snyk patches
    npm ERR! peerinvalid The package grunt does not satisfy its siblings’ peerDependencies requirements!
    npm ERR! peerinvalid Peer grunt-eslint@19.0.0 wants grunt@>=0.4.0
    npm ERR! peerinvalid Peer grunt-yamllint@0.2.0 wants grunt@~0.4.0

    npm ERR! System Linux 4.4.21+
    npm ERR! command “/usr/bin/nodejs” “/usr/bin/npm” "install"
    npm ERR! cwd /home/pi/MagicMirror
    npm ERR! node -v v0.10.29
    npm ERR! npm -v 1.4.21
    npm ERR! code EPEERINVALID
    npm ERR!
    npm ERR! Additional logging details can be found in:
    npm ERR! /home/pi/MagicMirror/npm-debug.log
    npm ERR! not ok code 0



  • Did you install the package?

    npm install snyk-protect

    Try to run it:

    npm run snyk-protect

    Does that work?



  • This is what I get when I run npm install snky-protect:

    pi@raspberrypi:~/MagicMirror $ npm install snyk-protect
    npm ERR! 404 Not Found
    npm ERR! 404
    npm ERR! 404 ‘snyk-protect’ is not in the npm registry.
    npm ERR! 404 You should bug the author to publish it
    npm ERR! 404 It was specified as a dependency of 'magicmirror’
    npm ERR! 404
    npm ERR! 404 Note that you can also install from a
    npm ERR! 404 tarball, folder, or http url, or git url.

    npm ERR! System Linux 4.4.21+
    npm ERR! command “/usr/bin/nodejs” “/usr/bin/npm” “install” "snyk-protect"
    npm ERR! cwd /home/pi/MagicMirror
    npm ERR! node -v v0.10.29
    npm ERR! npm -v 1.4.21
    npm ERR! code E404
    npm ERR!
    npm ERR! Additional logging details can be found in:
    npm ERR! /home/pi/MagicMirror/npm-debug.log
    npm ERR! not ok code 0
    pi@raspberrypi:~/MagicMirror $



  • @negativeflare

    Hm strange. Do you use npm version 0.10.29 on purpose?

    May you try to update:

    npm install npm -g
    npm update -g

    and also maybe clean cache:
    npm cache clean

    and than again to try install the package and his dependency.



  • Thanks! That fixed it.



  • npm install npm -g
    npm update -g
    

    install me npm version 4.1.2 which now only raises a warning for yamllint (since that package.json asked exactly for 0.4.0).
    Probably because of this : http://gruntjs.com/blog/2016-04-04-grunt-1.0.0-released#peer-dependencies

    No guarantee, but I think I have npm version 2 something before, which hard error on that issue.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.