MagicMirror² v2.8.0 is available! For more information about this release, check out this topic.

force_s3tc_enable overridden by environment.



  • This post is deleted!


  • I get the warning too, but MM does start.
    There are several hits using google.
    Seems to be a Chromium and HTML syntax issue.



  • i get warning but my MM doesn’t start i have tried so many solutions. but still no effect. do you have any idea where should i look for those HTML or chromium files ?



  • Sorry, no idea.
    You could disable all modules (disabled: true,) and then enable them one by one (disabled: false,) until the issue appears.

    But also run cd ~/MagicMirror; npm run config:check to be sure you do not have a config issue.
    Perhaps the ATTENTION is not related to the config.



  • Thanks i will try that and if solves that i will post it here 🙂

    there is one more issue npm lodash.update vulnerability. i don’t think so that those are connected to each other.



  • Are u using chrome as the browser?
    This error has been reported there frequently.

    Search force_s3tc_enable in google



  • Chromium. yeah i have seen many reports on google about this chrome/chromium 😞

    I think must be issue with the GPU or else the syntax . i am looking into it but cant find anything 😞



  • This post is deleted!


  • @siddhartha so, what does 'does not start ’ mean?

    npm start
    in the Magic Mirror folder gets the command prompt back? or not
    screen goes black, or not

    have you done

    export DISPLAY=:0
    npm start
    

    on my mm I also have to

    npm --enable-transparent-visuals --disable-gpu start
    


  • After upgrading OS. i faced problem with display.
    i fixed some problem with
    npm audit fix --force.

    Then i shifted to VNC
    used DISPLAY=:1 and then the magicmirror started.
    but now there ware two process running at time.

    MagicMirror with DISPLAY=:0
    MM with DISPLAY=:1

    so using pm2 i deleted MagicMirror and gave reboot.
    everything worked perfectly. so i changed back DISPLAY=:0 in MM.

    and gave reboot again…

    and problem solved. no black screen no error 🙂