MMM-SONOS showing then not showing


  • Project Sponsor

    Hi!
    So I have MMM-Sonos mostly working. ‘Mostly’ because it works normally for a few hours but then, when music has been stopped for a while, it won’t re-appear once music starts playing again. If I restart MM it shows up fine again.

    When it is not showing, the Sonos API server is still working and I can see the correct tracks on the web page (http://ip:5005/zones).

    The logs don’t show any errors so I don’t know where to start looking to troubleshoot it…

    Any ideas?



  • open the developers window

    ctrl-shift-i
    select the console tab
    and scroll up to find any errors (usually red text)


  • Project Sponsor

    Interestingly, when the dev window opens, it cause the MM screen to be re-drawn and it makes the Sonos modules appear.

    The console shows no errors…



  • Can u show your config for this module?


  • Project Sponsor

    This is my config. But I think I may have solved it. I was using CSS to hide the “Zone” and “Type” info. If I remove the “visibility hidden” it works. So let’s see after a full day…

    		{
    			module: 'MMM-Sonos',
    			//header: "Now Playing",
    			position: "bottom_bar", // This can be any of the regions, best results in center regions
    			classes: 'daytime_scheduler',
    			config: {
    				// See 'Configuration options' for more information.
    				showStoppedRoom: false,
    				showAlbumArt: true,
    				showRoomName: false,
    				exclude: ["Garden", "Living Room", "Bedroom"],
    			}
    		},