MagicMirror² v2.7.0 is available! For more information about this release, check out this topic.

ELIFECYCLE error after fresh install



  • @sdetweil Well I deactivated VNC, restarted and plugged my keyboard in the RasPi and this too didn’t change anything sadly.



  • @MrKnight230 ok, and u did the DISPLAY=:0



  • @sdetweil I actually didn’t but the result stays the same with “DISPLAY=:0”



  • @MrKnight230 and after u did the git pull of the new version, you did npm install in the MM folder and all modules with a package.json file, right?



  • @sdetweil I did run npm install again now and the output looks like this:

    pi@raspberrypi:~/MagicMirror $ npm install
    
    > magicmirror@2.7.1 install /home/pi/MagicMirror
    > cd vendor && npm install
    
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):
    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"arm"})
    
    audited 219 packages in 10.29s
    found 5 vulnerabilities (4 low, 1 high)
      run `npm audit fix` to fix them, or `npm audit` for details
    
    > magicmirror@2.7.1 postinstall /home/pi/MagicMirror
    > sh installers/postinstall/postinstall.sh && npm run install-fonts
    
    MagicMirror installation successful!
    
    > magicmirror@2.7.1 install-fonts /home/pi/MagicMirror
    > cd fonts && npm install
    
    audited 1 package in 1.092s
    found 0 vulnerabilities
    
    npm WARN acorn-jsx@5.0.1 requires a peer of acorn@^6.0.0 but none is installed. You must install peer dependencies yourself.
    npm WARN grunt-stylelint@0.10.1 requires a peer of stylelint@^9.0.0 but none is installed. You must install peer dependencies yourself.
    
    added 7 packages from 10 contributors, updated 6 packages and audited 3468 packages in 63.499s
    found 0 vulnerabilities
    

    But it again didn’t change anything.


  • Project Sponsor

    @MrKnight230 - The good news is that the npm install completed successfully. Hmm.

    Have you tried running Magic Mirror in server only mode and then hitting your mirror with a web browser?

    IMHO, I think the “fix vulnerabilities” feature of npm is causing more trouble than it is worth.



  • Hi guys, I just wanted to say thank you to @bhepler and @sdetweil for trying to help me with this problem.

    In the end I just used a very old backup at first and updated it, which worked fine at first and yesterday I tried setting my RPi up from scratch again and it worked perfectly!

    I’m sorry for anybody who encounters the same error and tries finding answers here, sadly there doesn’t seem to be a perfect solution for this.

    MrKnight230