MagicMirror² v2.7.0 is available! For more information about this release, check out this topic.

Weather forecast issues



  • Updated to 2.7.1 and I am using the new weather module. Everything appears to be working but I am finding that after a week or so, the forecast will stop refreshing. I currently using the current weather portion and the forecast portion of the module, but I haven’t noticed any issues with the current weather portion. I also have both set to use openweather. I had originally tried using darksky to get a longer forecast but it also seemed to have the same issue. Reloading the browser loads fresh data so I haven’t needed to reload MM to get fresh data, which leads me to think maybe its a browser issue? I included the section of the config file for the weather stuff for giggles.

                    {
                            module: "weather",
                            header: "Surrey, ND",
                            position: "top_right",
                            config: {
                                    apiKey: "#####", // private; don't share!
                                    type: "current",
                                    degreeLabel: true,
                                    locationID: "5690532",
                                    appendLocationNameToHeader: false
                             }
                    },
                    {
                            module: "weather",
                            position: "top_right",
                            config: {
                                    //weatherProvider: "darksky",
                                    //apiKey: "####", // private; don't share!
                                    //apiBase: "https://cors-anywhere.herokuapp.com/https://api.darksky.net",
                                    apiKey: "####",
                                    locationID: "5690532",
                                    lat: "48.23",
                                    lon: "-101.14",
                                    colored: "true",
                                    type: "forecast",
                                    tableClass: "medium",
                                    fade: "false",
                                    roundTemp: "true",
                                    maxNumberOfDays: "10",
                                    weatherEndpoint: "/forecast"
                            }
                    },
    
    

  • Module Developer

    I just noticed mine also experiences this behavior every few days. Even though it should reload the data with the updateInterval every few hours. Screenshot is from the browser Dev Tools on the Pi
    0_1556138954227_5f639727-d54e-44d4-9961-892d34714fad-image.png
    Can you check your Dev Toolbar when this happens?



  • @vinp said in Weather forecast issues:

    I just noticed mine also experiences this behavior every few days. Even though it should reload the data with the updateInterval every few hours. Screenshot is from the browser Dev Tools on the Pi
    0_1556138954227_5f639727-d54e-44d4-9961-892d34714fad-image.png
    Can you check your Dev Toolbar when this happens?

    I appear to be getting the same error code.



  • @mikepelchy if you stop and restart mm does the error go away for a while again?



  • @sdetweil said in Weather forecast issues:

    @mikepelchy if you stop and restart mm does the error go away for a while again?

    Yes, seems like it goes 2-3 days before the issue comes back. I have tried it with the MM viewer that opens on bootup and also in chromium.

    Tried using darksky when I first setup the new module and I seemed to have an issue with it, which I am thinking was the same issue so I switched back to darksky to see what happens.

    I also setup another RPI3 running a clean install to see what happens.


  • Module Developer

    I have not see the error since I last posted nearly 2 weeks ago



  • So I am even seeing the issue with using Darksky. However, I did to a clean install on a different RPI3 and that hasnt seem to have any problems with using OpenWeather as the supplier. So, it must be something with my install.



  • So as it turns out, even my clean install is seeing the same issue. And if I leave them both going long enough without restarting them, the current weather will also stop updating.