MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Would this cause a conflict with MMM-RemoteControl

  • Ok, so right now I have 2 mirrors running in my house. On one of the mirrors I can get the remote control function to work with no issue when I am in my house. I just tried the other and its not working. The config is the same on both, I copied/pasted to make sure.

    Yes I am using the proper IP of the 2nd mirror. I get the can not get remote/html error.

    The only thing I can think of is on the 2nd mirror I have the VNC cloud service turned on as this is a gift mirror and I want to be able to access it remotely for changes etc. If it doesn’t work because of this no biggie, I can add a usb keyboard & mouse to the gift for shut down purposes.

    Everything else looks the same. I guess I could turn off vnc cloud but I havent.

    Thanks in advance

  • what ip address are u trying to use, I think remotely or locally?

    if locally (on the house wifi), then VNC cloud will cause a problem you will have to use the vnc address, go out to the cloud and back in…

  • @sdetweil it was the same IP address that I used before installing VNC cloud. Even if I’m not accessing the mirror through VNC the error occurs. I did go into VNC on the mirror, went to settings and disabled accept cloud connections. Still no luck.

    I was wanting to make it easier to shut down for moving the mirror but me having remote access is more important so I can troubleshoot.

  • I can access it via cloud service now that it’s on their wifi but they can’t get remote to get past the get error.

  • @motdog everything I see says the vnc connection requires a vnc client… local or remote
    (and once u establish the vnc server, that connection requires the client, no direct connections anymore)…

    realvnc is the product for pi…

  • @sdetweil the thing is before I set it up for a cloud connection for me to access it remotely, I could access it via MMM-Remote-Control as it was in my home. When I established the cloud connection with VNC, remote quit working. Get the get error

  • @motdog right… the vnc connection take over ALL communications from the outside in…

    you should be able to use a vnc client on the local lan to connect to the pi… called direct connect

    but apps (like request TO remote-control) cannot go IN to the system except over vnc…(as I understand it)

  • @sdetweil ok got it. Was just trying to figure out how to adjust screen brightness like I would with the app. makes sense

Log in to reply