Third Party modules does not work



  • Hello guys,
    I have got a little problem, after countless tries I managed to do npm install && npm start (before on Rpi 2 B+ worked only serveronly - electron and node needed to be installed manually, do not know why) and “everything” works fine… except 3rd party modules.

    Tried a lot of them but every time I add some in config and reload MM , screen stays black, when I remove 3rd party module from config it works like a charm…and I am positive that in config I typed everything right.

    Does anyone know where is the problem? :)

    Thank you very much!


  • Moderator

    @indigomejor Please check the installation notes of the modules again, and see if there are any steps you might have overlooked. Also you can have a look at the output of the server (i.e. pm2 logs mm if you are using the pm2 method), and check for errors there, and post them here (remove confidential information first!).


  • Moderator

    Are you sure the third party modules are installed in their own folder in MagicMirror/modules ?



  • @yawns I think I installed them in modules/default folder, that should be the problem maybe


  • Moderator

    @indigomejor said in Third Party modules does not work:

    @yawns I think I installed them in modules/default folder, that should be the problem maybe

    I guess so. I just moved one of my modules on my test laptop into the default subfolder and my screen stays black, just as you described.
    I moved it back to the modules folder, restarted the mirror and the module is shown



  • @yawns Yes, it was folder problem, my bad, I just wanted to have some order in it :)
    Thank you guys for help!

    For future mirrores with same problem, always put 3rd party modules in …/MagicMirror/modules (NOT in default) :)


  • Moderator

    @indigomejor
    glad to see it was such a simple thing. Enjoy your mirror



  • Hey guys,

    I also have a problem with 3rd party modules.

    I tried to add MMM-PublicTransportBerlin and MMM-soccer, but both are not working. After adding the modules the mirror shows just “loading” at the given position. Both modules are installed in: /MagicMirror/modules/ in seperated folders.

    Here you can see my entries in the config to the mentioned modules:

    {
    module: ‘MMM-PublicTransportBerlin’,
    position: ‘top_right’,
    config: {
    name: “Alexanderplatz”,
    stationId: 9100003,
    hidden: false,
    ignoredStations: [9100003,2342,1337],
    excludedTransportationTypes: ‘bus,suburban,subway’,
    delay: 10,
    interval: 120000,
    departureMinutes: 10,
    maxDepartures: 15,
    marqueeLongDirections: true,
    showColoredLineSymbols: true,
    useColorForRealtimeInfo: true,
    showTableHeadersAsSymbols: true,
    maxUnreachableDepartures: 3,
    maxReachableDepartures: 7,
    fadeUnreachableDepartures: true,
    fadeReachableDepartures: true,
    fadePointForReachableDepartures: 0.25
    }
    },

    {
    module: ‘MMM-soccer’,
    position: ‘bottom_right’,
    config: {
    api_key: ‘my key’,
    colored: ‘false’,
    show: ‘GERMANY’,
    leagues: ‘{“GERMANY”:430}’
    }
    },

    Would be great if anybody can help! All default modules are working correctly.

    Thank you!


  • Moderator

    Did you reboot your raspberry pi or the mirror process?



  • Thanks for this advice. The module for public transports is working correnctly now! But I still have problems with the soccer module. It still shows “loading”. Any ideas? Maybe the syntax in the last line with leagues: … ???

    Thank you!


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.