MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

At my Wits end! Overscan/Underscan. Nothing changes



  • Hi Folks
    I have played around with this for hours on end. I have the Raspi up and running and have got MagicMirror installed. But for the love of money I can’t get the screen to stop overflowing past the edge of the monitor. The image I can see if too big for the screen i am using.
    In Raspi Configuration I have tried Underscan both Enabled and Disabled.
    In the config file i have tried allsorts of combinations of the following code…

    disable_overscan=1
    
    overscan_left=39
    overscan_right=39
    overscan_top=25
    overscan_bottom=23
    framebuffer_width=1920
    framebuffer_height=1080
    hdmi_group=1
    hdmi_mode=16
    

    Whether disabled or not, positive or negative values nothing makes any difference the the results I get.
    Its like a setting somewhere is overriding any of these settings.
    Can someone please take pity of a guy whose gonna rip his hair out anytime soon.
    Best Regards



  • is this the pi desktop that is too big, or the MagicMirror UI ?



  • @sdetweil It is the Pi desktop that is too big mate. but equally makes the MM too big too when launched.



  • @JonoGee ok… don’t have a solution myself, just trying to help others get clear idea of problem… I searched and all the things I saw are the same as what you have done



  • @JonoGee

    See these URLs for details, if not known already:
    https://www.raspberrypi.org/documentation/configuration/hdmi-config.md
    https://www.raspberrypi.org/documentation/configuration/config-txt/video.md

    Can you try this ?

    $ tvservice -m CEA
    $ tvservice -m DMT
    

    This will give you the hdmi_group that can be used and the preferred hdmi_mode.

    hdmi_group=1
    hdmi_mode=16
    

    This means CEA 1080p @60Hz.

    And what happens when you comment out disable_overscan and the overscan settings ?



  • @evroom
    Hi buddy,
    I tried disabling out all overscan settings etc. It didn’t make the slightest change, neither did…

    hdmi_group=1
    hdmi_mode=16
    

    I am not sure where i should be putting…

    $ tvservice -m CEA
    $ tvservice -m DMT
    

    I checked out those links and nothing I do at all makes any change whatsoever. I see no adjustment or anything. I’d be happy if i did then i could keep adjusting, rebooting, and re-adjust accordingly until it was right.

    THankyou for your time anyway trying to help me sort this. I really appreciate it.
    BR



  • @JonoGee said in At my Wits end! Overscan/Underscan. Nothing changes:

    I am not sure where i should be putting…

    They are not config entries.
    Just execute those commands from the command-line.

    The config file entries in your first post, are they yours or just an example ?

    Let’s start with the tvservice commands.
    Please post the output, then we take it from there.

    $ tvservice -m CEA
    $ tvservice -m DMT
    $ tvservice -s
    

    Not an expert on the topic, but who knows we straighten this out together 🙂



  • Sometimes you can fix/set overscan in the menu of the monitor, may be this helps?



  • @cirdan It was displaying fine with a black border actually during the Raspi setup and I ticked something during setup and its been like this since.



  • Any other device, PC, DVD Player, PS4, what ever i plug it its fine. Raspi homepage. spilling outside screen area.


Log in to reply