MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

Touchscreen not working in MM - MM freezing one's a day



  • Heya Folks,

    so I got 2 Problems there.

    Everyday in the morning (so this happens ones a day), when i turn on my LCD i got the MM with a stillstanding time and no newsfeed Output.
    Ok, thought this is a bit awkward, so i tried to restart it.

    -> pm2 restart mm
    -> pm2 tells me all is fine

    Take a look back on my monitor, nothing happend, still frozen. Tried it also with start/stop, still frozen. Only a complete reboot fixes this.
    I think this is mainly not a problem of MM, but maybe some of u guys could have a clue, what i can do on my server to change this. Maybe the graphical output needs a reset sometimes.

    Next thing is the touchfoil on my LCD. I got it to work under my Debian with xinput. On the GNOME desktop, everything is fine, calibration works, calibration does not reset on a reboot. Now i installed the mm-hide-all button module and tried to tap on the screen: nothing.
    Ok… maybe… let’s do a restart. Oh, nothing. Next try was kioskmode. And this is where things get weird for me. On my first start MM has a top cell like every program has with Close, do this, do that… There is the touch working, BUT not on the main MM window.
    I got no clue about programming in node, i think maybe there is somewhere a point, where i could add the touch as an Input for MM. Or maybe there is another thing to do? I don’t know exactly. Hope someone could help me there, to make elements clickable with an Input from /dev/ttySx.

    So Long,
    chrisyy



  • Found out for mysel, that when I open the Webpage in another browser on another PC, the on.click event still does not work and the cursor hides as i place it over the mirror space. Maybe that’ll help.



  • @chrisyy The cursor being hidden is done through a CSS line. That’s probably not the issue.

    I know that @broberg was having issues with click events not firing due to z-order issues. Perhaps this discussion will point you down the correct path.



  • Ok, i figured out that this was nearly the same issue as z-index.

    I took a look at the .css and .html and found out that in the index.html this line:

    is something like a fullscreen container that lay's his self over the screen.

    So after commenting out the line, i can click the button. But the only thing hiding is the button itself, maybe thats just because i’m sitting on a laptop (not at home) and trying it throug my webbrowser. After refreshing it is hidden and blending back in when i click on the some space where the button was before. I’ll give it a try when i’m back home and hopefully it will work.

    I’ll take a look to #debian to try to get help with the monitor freeze and post results here.



  • @chrisyy If you check the MagicMirror2 documentation, you’ll see that there are several regions that you can easily assign any module. top_left, bottom_center, middle_right and the like. The region fullscreen_above is just what it sounds like: It’s “above” every other module area and it takes up the entire screen.

    So, you’ve just removed this layer from your mirror. So long as you don’t attempt to put a module in that region, you should be okay. Of course… if you re-enabled it and put the module that you wanted to click upon in there, it should also work.

    As an aside, I was playing around with showing a Halloween video on the mirror and we put it in fullscreen_below. This allowed all of the other modules to be shown on top of the video. Very cool effect.



  • Indeed this is good to know to create funny effects.

    I’m working on the second Problem also. A guy in #ubuntu suggested me to try it with lxde instead of gnome. Maybe its a bug in gnome.