MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

error: Pulling is not possible because you have unmerged files.



  • Hi all,

    Trying to update Magic Mirror to the latest version after receiving a message on my mirror, I have always had issues updating the Mirror software but the messages provided to me in the past have always been helpful and I have manged to muddle my way through and get updated.

    Now after issuing git pull && npm install in the Magicmirror directory, all I get is the below…

    error: Pulling is not possible because you have unmerged files.
    hint: Fix them up in the work tree, and then use 'git add/rm ’
    hint: as appropriate to mark resolution and make a commit.
    fatal: Exiting because of an unresolved conflict.

    I have no idea what these can be, in the past I have always had issues with package lock json and vendor package lock json but the errors provided previously have always helped and offered explanations.

    I am running the stock mirror software with the Google Photos module added, can anybody help me to understand what the above message means and where I can fix it to enable me to update?

    Thank you in advance.



  • @DazTypeR please try the new upgrade script (will be part of next release)

    see https://forum.magicmirror.builders/topic/10859/new-update-upgrade-script-ready-for-testing



  • So i just CD into the MagicMirror directory and then run the top command, if that works, then run the 2nd?



  • @DazTypeR no… don’t need to cd, just execute the script, it will figure it out and ask you to save any changed files

    note… first time is a test install, doesn’t change anything…

    then, if all is good, run it again with apply parameter



  • OK, so I ran the first script, how do i actually know if it worked?



  • @DazTypeR if you ran it without any parms at the end, it did not make ANY changes… it was a test, to make u feel comfortable and see the process once… (I don’t want to mess up your system, so it it find an error it cant fix, it tells you, and stops

    now, run it again and add the word ‘apply’ at the end



  • Sorry, probably didnt make myself clear.

    I knew the 1st script would not make any changes, how do i know the script worked and did not mess anything up?

    I dont see any messages output to the command line, it just finished.

    Sorry about my lack of understanding, I`m trying to learn as I go but its a long slog.

    This is the last thing it put out…

            fi
            # return to original folder
            cd - >/dev/null
            date +"Upgrade ended - %a %b %e %H:%M:%S %Z %Y" >>$logfile
    else
            echo It appears MagicMirror has not been installed on this system
            echo please run the installer, "raspberry.sh" first
    fi
    


  • @DazTypeR
    ok… the UPDATE script only updates… do you have a ~/MagicMirror folder??
    it sounded like you did, cause you were trying to do a git pull

    just go run your mirror again… again, it makes NO changes to your local working copy.
    (it did download updates to the local git repo (~/MagicMirror/.git folder), but did not apply any updates)

    post the log from ~/MagicMirorr/installers/upgrade.log

    please use the markdown code block feature…
    paste the log text, select the text.
    push the </> button



  • Yes I have a MagicMirror folder as I have managed to run my mirror for 10 months and have managed to do 2 upgrades in that time but in the past it has always told me what the error is and mostly how to fix it.

    With regards to posting the log, there is no upgrade.log file in that directory?



  • @DazTypeR no log file… hm…
    which sounds like your MagicMirror folder is not called ‘MagicMirror’

    look in user home folder ~/


Log in to reply