MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Conversation Error: { Error: 14 UNAVAILABLE: Service unavailable.



  • I have a problem when I start the magic mirror. Everything seems to boot as it should but the google assistant does not listen to me. So I press the widget to start it manually but doesn’t listen either.

    Here you can see the part of the log where it gets errors:

    [HOTWORD] begins.
    [HOTWORD] Detector starts listening.
    [HOTWORD] stops.
    [HOTWORD] Final Result: { detected: false }
    [HOTWORD] begins.
    [HOTWORD] Detector starts listening.
    [AMK2] assistant ready
    [AMK2] Conversation starts.
    [AMK2] Started with text query: brief today
    { requestId: ‘5dbd29c0-0000-2458-852e-089e08276030’ } { profileFile: ‘default.json’, lang: ‘en-US’ }
    [AMK2] Device Action: { requestId: ‘5dbd29c0-0000-2458-852e-089e08276030’ }
    [AMK2] Assistant Text Response:
    [AMK2] Conversation Completed
    [HOTWORD] stops.
    [HOTWORD] Final Result: { detected: false }
    [HOTWORD] begins.
    [HOTWORD] Detector starts listening.
    [AMK2] assistant ready
    [AMK2] Conversation starts.
    [AMK2] Assistant Text Response:
    [AMK2] Conversation Error: { Error: 14 UNAVAILABLE: Service unavailable.
    at Object.exports.createStatusError (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/common.js:91:15)
    at ClientDuplexStream._emitStatusIfDone (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/client.js:233:26)
    at ClientDuplexStream._receiveStatus (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/client.js:211:8)
    at Object.onReceiveStatus (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/client_interceptors.js:1306:15)
    at InterceptingListener._callNext (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/client_interceptors.js:568:42)
    at InterceptingListener.onReceiveStatus (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/client_interceptors.js:618:8)
    at /home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/client_interceptors.js:1123:18
    code: 14,
    metadata:
    Metadata { _internal_repr: { ‘content-disposition’: [Array] }, flags: 0 },
    details: ‘Service unavailable.’ }

    1_1572718840181_Captura de pantalla (18).png 0_1572718840181_Captura de pantalla (17).png


  • Module Developer

    Remove useWelcomeMessage. It needs more complex configuration. If you don’t need it really, just remove from config.js



  • Still doesn’t work. It shouldn’t be a mic problem because it gets detected and I can record myself.

    Getting this log:

    pi@raspberrypi:~ $ cd MagicMirror
    pi@raspberrypi:~/MagicMirror $ npm start

    magicmirror@2.9.0 start /home/pi/MagicMirror
    sh run-start.sh

    Starting MagicMirror: v2.9.0
    Loading config …
    Loading module helpers …
    No helper found for module: alert.
    Initializing new module helper …
    Module helper loaded: updatenotification
    No helper found for module: clock.
    Initializing new module helper …
    Module helper loaded: calendar
    No helper found for module: compliments.
    No helper found for module: currentweather.
    No helper found for module: weatherforecast.
    Initializing new module helper …
    Module helper loaded: newsfeed
    Initializing new module helper …
    Module helper loaded: MMM-Hotword
    Initializing new module helper …
    Module helper loaded: MMM-AssistantMk2
    All module helpers loaded.
    Starting server on port 8080 …
    Server started …
    Connecting socket for: updatenotification
    Connecting socket for: calendar
    Starting node helper for: calendar
    Connecting socket for: newsfeed
    Starting module: newsfeed
    Connecting socket for: MMM-Hotword
    [HOTWORD] MMM-Hotword starts
    Connecting socket for: MMM-AssistantMk2
    Sockets connected & modules started …
    Launching application.
    Create new calendar fetcher for url: http://www.calendarlabs.com/ical-calendar/ics/76/US_Holidays.ics - Interval: 300000
    Create new news fetcher for url: http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml - Interval: 300000
    [AMK2] Recipe is loaded: hide_and_show_all_modules.js
    [AMK2] Recipe is loaded: reboot.js
    [AMK2] Recipe is loaded: screen_onoff.js
    [AMK2] Recipe is loaded: shutdown.js
    [AMK2] Temporal storage directory is clearing.
    [HOTWORD] begins.
    [HOTWORD] Detector starts listening.
    [HOTWORD] stops.
    [HOTWORD] Final Result: { detected: false }
    [HOTWORD] begins.
    [HOTWORD] Detector starts listening.
    [AMK2] assistant ready
    [AMK2] Conversation starts.
    [AMK2] Assistant Text Response:
    [AMK2] Conversation Error: { Error: 14 UNAVAILABLE: Service unavailable.
    at Object.exports.createStatusError (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/common.js:91:15)
    at ClientDuplexStream._emitStatusIfDone (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/client.js:233:26)
    at ClientDuplexStream._receiveStatus (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/client.js:211:8)
    at Object.onReceiveStatus (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/client_interceptors.js:1306:15)
    at InterceptingListener._callNext (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/client_interceptors.js:568:42)
    at InterceptingListener.onReceiveStatus (/home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/client_interceptors.js:618:8)
    at /home/pi/MagicMirror/modules/MMM-AssistantMk2/node_modules/grpc/src/client_interceptors.js:1123:18
    code: 14,
    metadata:
    Metadata { _internal_repr: { ‘content-disposition’: [Array] }, flags: 0 },
    details: ‘Service unavailable.’ }



  • I solved it!!. The assistant mk2 module now hears to my mic! and answers!



  • @FLOW-THE-NOOB How did you solve it? Im having the same issue, please tell me.



  • @09succotash Go to your desktop. Right click on the volume icon. Choose your recording and playback devices. Adjust their volumes to max in audio device settings.

    0_1574525003718_Captura de pantalla (37).png



  • Oh, ok. That makes sense.



  • @FLOW-THE-NOOB
    Hi. I have the same problem, the only difference is that I have the speakers for HDMI. Any solution?



  • @juantata

    Putting sound through hdmi didn’t work for me neither. Only USB and headphone jack worked for me for speakers. The mic has to be a usb one though.


Log in to reply