MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

disabled modules MMM-moduleScheduler



  • Hello everybody,

    i have a lot of modules on my magicmirror and i’m using MMM-Pages to rotate them…it’s a good configuration for me…but i’m trying to perfect it. i need only to display only four modules at 7h00 , 12H00 et 18h00…So, i’m testing MMM-Modulescheduler…and it’s not the best solution because other modules are only hidde and not disabled…At 7h00, four modules are display but MMM-Pages is always active. I would like to have modules with rotate except at 7, 12 and 18h00 to have four modules fix with their positions
    here an exemple of my config.js for 7h00 (and sorry for english) :

        		{
            		module: 'MMM-ModuleScheduler',
            		config: {
                			// Montre tous les modules de 06h00 à 18h35. Montre que les modules ignorés à partir de 18h35
                			global_schedule: {from: '05 7 * * *', to: '59 11 * * *', ignoreModules: ["MMM-EmbedYoutube" , "clock" , "newsfeed" ,  "MMM-DarkSkyForecast"] },
            			}
        		},
    		{
            		module: "MMM-pages",
    			disabled: false,
            		config: {
                    		modules:
    				[[ "MMM-EmbedYoutube" , "clock" , "newsfeed" ,  "MMM-DarkSkyForecast" ],
    				[ "MMM-EmbedYoutube" , "clock" , "newsfeed" ,  'MMM-Lunartic' , 'MMM-rfacts' ],
    				[ "MMM-EmbedYoutube" , "clock" , "newsfeed" , "calendar", "calendar_monthly" ],
    				[ "MMM-EmbedYoutube" , "clock" , "newsfeed" , "MMM-cryptocurrency" ],
    				[ "MMM-EmbedYoutube" , "clock" , "newsfeed" , "MMM-Cocktails" , 'MMM-SystemStats' ],
    				[ "MMM-EmbedYoutube" , "clock" , "newsfeed" , "MMM-NowPlayingOnSpotify" , 'MMM-rfacts' ],
    				[ "MMM-EmbedYoutube" , "clock" , "newsfeed" , 'MMM-MovieListings' , 'MMM-SystemStats' ]],
            			rotationTime: 7000,
    				}
        		},
    

    Thanks if you have some idea…

    See you



  • The best way wil be to disabled MMM-Pages at 7h00…at 12h00…


Log in to reply