MM-Calendar Doesn't Seem to Follow Some Config Options



  • This is a new setup on my first MM, so it may not be related to the calendar at all. In the event that it is, here’s my setup:

    {
                            module: "calendar",
                            header: "Shared Calendar",
                            position: "top_left",
                            config: {
                                    calendars: [
                                            {
                                                    symbol: "calendar-check",
                                                    maximumEntries: 25,
                                                    wrapEvents: true,
                                                    fetchInterval: 900000,
                                                    fade: false,
                                                    fadePoint: 1,
                                                    url: "https://calendar.google.com/calendar/ical//basic.ics"                          }
                                                    /*url: "webcal://www.calendarlabs.com/ical-calendar/ics/76/US_Holidays.ics"                                     }*/
                                    ]
                            }
                    },
    

    I have the following issues:

    • I do not appear to be getting more than the default ten entries
    • I say “appear” because the list of entries is fading at the bottom
    • I can’t tell any difference between the default fadePoint and the hard-coded one

    I know that these variables are supposed to override the global settings, but I don’t even know if (where?) those are coded if not directly into the code itself.

    Does anyone have any thoughts?


  • Project Sponsor

    You have placed config options within the calendars array, that is why it uses the default options.

    {
                            module: "calendar",
                            header: "Shared Calendar",
                            position: "top_left",
                            config: {
                                                    maximumEntries: 25,
                                                    wrapEvents: true,
                                                    fetchInterval: 900000,
                                                    fade: false,
                                                    fadePoint: 1,
                                    calendars: [
                                            {
                                                    symbol: "calendar-check",
                                                    url: "https://calendar.google.com/calendar/ical//basic.ics"                          }
                                                    /*url: "webcal://www.calendarlabs.com/ical-calendar/ics/76/US_Holidays.ics"                                     }*/
                                    ]
                            }
                    },
    


  • @broberg

    Thanks for the reply. While adjusting as you’ve mentioned does give me the expected result, I have to say that it seems counter-intuitive.

    Placing those settings OUTSIDE of the calendar definition seems to make them overrides for the defaults and would make them be the settings used for all calendars. Shouldn’t setting them per-calendar need to be done within the definition of the calendar itself?


  • Project Sponsor

    @ember1205 yes, the config options are for the entire module not individual calendars.

    These are the options you can change for each calendar entry : https://github.com/MichMich/MagicMirror/tree/master/modules/default/calendar#calendar-configuration-options



  • @broberg

    Why do some of the more general config options throw errors stating that they are undefined? For example, I can’t set tableClass or timeFormat as the values I chose (xmall and absolute, respectively) throw errors and prohibit MM from starting. I have these defined in the general config section.



  • @ember1205 all words to the right of the : in a setting need to be in quotes, and usually each line will end with a comma. Numbers and true/false do not need quotes



  • @sdetweil

    I will try quoting them.

    It hadn’t occurred to me that “words” need to be quoted since true and false do not.



  • Quoting the values corrected the issues I was having with them. I think I’m good with this now and appreciate the help.