MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

MMM-ArduPort



  • I’m having trouble setting up MMM-ArduPort. So if anyone can help…

    I have to point out that I’m using SAME serial port on arduino for communication with raspberry and RS485 network. For transmiting and receiveing data on RS485 I use fantastic EasyTransfer arduino library.

    Posible problem:
    When arduino receives data from RS485, it gets to TX pin on USB side and never gets to raspberry. Wich is good.
    When arduino is sending data, to transmit over RS485, it first have to activate transmision mode on RS485 module.
    In this situation, data is being sent from arduino TX to RS485 RX. But it is allso sent to USB RX, and to raspberry. Wich is bad. I gues.

    Here are symptoms:
    MM starts and ArduPort is waiting for arduino.
    I connect arduino, ArduPort receives “[status:setup:starting]” and “[status:setup:started]”
    ArduPort shows my sensors list and then it removes them and returns to “Waiting for connection…”

    My arduino code sends “[status:setup:starting]”, waits for 3 seconds and sends “[status:setup:started]” witch is normaly received by Arduport.
    But! Arduino then sends request for sensors status to RS485 wich is allso transmited to raspberry. I think that in this moment it switches to “Waiting for connection”.

    But, again, I have modified MMM-ArduPort.js so it doesen’t disconnect (commented ), and I have aded “this.isArduinoStarting = false;” and “this.isArduinoStarted = true;” right after "case ‘sensor’: "
    I modified this so arduino always stays connected, and data should be displayed whenever and whatever sensor data is received. And it actualy does switch to listing my sensors, but, again, sensor data isn’t shown.

    I taught that EasyTransfer requests that get to PI are chrashing communication, but after my mod, I can see that data is passed normaly and is not affected by EasyTransfer part.
    I gues, that part is discarded at this part in arduino.py

    match = re.match(rgxData, data)
    if match:
                data = data[1:-1]
                case, name, value = data.split(":")
                to_node(case.lower(), {"name": name, "data": value})
    

    Here is photo of data being received on screen /dev/ttyUSB0 (yes… photo. I was in a hurry…)
    0_1578411025419_IMG_20200107_120847384 (Small).jpg

    Pictograms between [sensor:name:data] are EasyTransfer requests.

    I’ve even tryed this modification. It didn’t help.



  • I have reinstaled all original files for arduport and started debuging… Again.😅

    I didn’t mention it before, but I’m running MM on Raspbian lite.
    I’ve found I had problems with python. Force reinstalling modules solved it.

    I have allso found some errors in arduino.py,
    Had to change:

    rgxData = re.compile("[[][a-zA-Z0-9-].*[\:][a-zA-Z0-9-].*[\:][a-zA-Z0-9-.].*[\]]")
    

    to

    rgxData = re.compile("[[][a-zA-Z0-9\-].*[\:][a-zA-Z0-9\-].*[\:][a-zA-Z0-9\-\.].*[\]]")
    

    and

    incoming = self.arduino.readline(self.arduino.in_waiting).decode('ascii').replace('\r', '').replace('\n', '')
    

    to

    incoming = self.arduino.readline(self.arduino.in_waiting).decode('ascii', errors="ignore").replace('\r', '').replace('\n', '')
    

    Now, when running

    python arduport.py
    

    I get this:

    {"debug": "SerialPort shell started..."}
    {"debug": "Waiting Ardunio to connect on port..."}
    {"status": {"data": "connected", "name": "connect"}}
    {"status": {"data": "starting", "name": "setup"}}
    {"status": {"data": "started", "name": "setup"}}
    {"sensor": {"data": "0.02", "name": "Baterija"}}
    {"sensor": {"data": "-0.00", "name": "Struja"}}
    {"sensor": {"data": "0.00", "name": "Solarno"}}
    {"sensor": {"data": "-0.12", "name": "Panel"}}
    {"sensor": {"data": "-0.00", "name": "Inverter"}}
    {"sensor": {"data": "0.04", "name": "Baterija"}}
    {"sensor": {"data": "-0.00", "name": "Struja"}}
    {"sensor": {"data": "0.00", "name": "Solarno"}}
    

    I’m guesing, this should be working now. But ArduPort is still stuck at “Waiting for connection…”

    Here is C/P from my config.js

                  {
                  module: "MMM-ArduPort",
                  position: "top_right",
                  header: "Solarni sustav",
                  config:{
                          portname: "/dev/ttyUSB0",
                          updateInterval: 1,
                          animationSpeed: 1000,
                          displayIcons: false,
                          showDescriptopn: true,
                          hideLoading: false,
                          hideWaiting: false,
                          useColors: false,
                          sensors: [
                                  {
                                  name: "Solarno",
                                  description: "Solarni sustav",
                                  maxValue: 5,
                                  maxFormat: "({0}) ",
                                  highestValue: 4,
                                  highestFormat: "({0}) Greska - pregrijavanje",
                                  highValue: 3,
                                  highFormat: "({0}) Greska - preopterecenje",
                                  lowValue: 2,
                                  lowFormat: "({0}) Backup mod",
                                  lowestValue: 1,
                                  lowestFormat: "({0}) Ukljuceno",
                                  minValue: 0,
                                  minFormat: "({0}) Iskljuceno"
                                  },
                                  {
                                  name: "Baterija",
                                  description: "Stanje baterije",
                                  maxValue: 26,
                                  maxFormat: "({0} V) Balansiranje",
                                  highestValue: 25.5,
                                  highestFormat: "({0} V) 100%",
                                  highValue: 24.87,
                                  highFormat: "({0} V) 75%",
                                  lowValue: 24.2,
                                  lowFormat: "({0} V) 50%",
                                  lowestValue: 11.74,
                                  lowestFormat: "({0} V) 25%",
                                  minValue: 23.2,
                                  minFormat: "({0} V) 0%"
                                  },
                                  {
                                  name: "Struja",
                                  description: "Punjenje ili praznjenje",
                                  maxValue: 20,
                                  maxFormat: "({0} A) Punjenje",
                                  highestValue: 10,
                                  highestFormat: "({0} A) Punjenje",
                                  highValue: 0,
                                  highFormat: "({0} A) ",
                                  lowValue: -20,
                                  lowFormat: "({0} A) Praznjenje",
                                  lowestValue: -40,
                                  lowestFormat: "({0} A) Brzo preznjenje",
                                  minValue: -60,
                                  minFormat: "({0} A) PREOPTERECENJE"
                                  },
                                  {
                                  name: "Panel",
                                  description: "Snaga solarnih panela",
                                  maxValue: 500,
                                  maxFormat: "({0} W)",
                                  highestValue: 400,
                                  highestFormat: "({0} W)",
                                  highValue: 300,
                                  highFormat: "({0} W)",
                                  lowValue: 200,
                                  lowFormat: "({0} W)",
                                  lowestValue: 100,
                                  lowestFormat: "({0} W)",
                                  minValue: 0,
                                  minFormat: "({0} W)"
                                  },
                                  {
                                  name: "Inverter",
                                  description: "Potrosnja invertera",
                                  maxValue: 1000,
                                  maxFormat: "({0} W)",
                                  highestValue: 800,
                                  highestFormat: "({0} W)",
                                  highValue: 600,
                                  highFormat: "({0} W)",
                                  lowValue: 400,
                                  lowFormat: "({0} W)",
                                  lowestValue: 200,
                                  lowestFormat: "({0} W)",
                                  minValue: 0,
                                  minFormat: "({0} W)"
                                  }
                                  ]
                          }
                  },
    

    EDIT:

    Here is C/P from chrome console:

    Starting module: MMM-ArduPort
    MMM-ArduPort.js:286 [MMM-ArduPort]:: MMM-ArduPort: status
    MMM-ArduPort.js:286 [MMM-ArduPort]:: MMM-ArduPort: {
        "action": "status",
        "name": "initialized"
    }
    MMM-ArduPort.js:286 [MMM-ArduPort]:: MMM-ArduPort: error
    MMM-ArduPort.js:286 [MMM-ArduPort]:: MMM-ArduPort: "pyshell-throw"
    MMM-ArduPort.js:123 [socketNotificationReceived::error]:
    


  • @Kereknjek said in MMM-ArduPort:

    MMM-ArduPort.js:286 [MMM-ArduPort]:: MMM-ArduPort: error
    MMM-ArduPort.js:286 [MMM-ArduPort]:: MMM-ArduPort: “pyshell-throw”
    MMM-ArduPort.js:123 [socketNotificationReceived::error]:

    yes, according to the code, this notifies the module that the python script running in the background ended, unexpectedly.

    I would try running it from the commandshell in the foreground without the MM and see what is going on



  • How do I do that?



  • It seems I’m having isues with Python.

    I have reinstaled Python and Python3, npm, python-shell and node js. Nothing worked. It was sending errors even with blank arduino, arduino sending only “starting” and “started” commands…
    So, due to my lack of knowlege of Python or anything else surrounding ArduPort, I’m abandoning it…

    To bad. It is very elagant module.



  • @Kereknjek said in MMM-ArduPort:

    How do I do that?

    on the pi, ctrl-alt-t, will open a terminal window, you can also ssh into the pi

    then execute the command that the module would use

    python .......  whatever
    

    I see u dropped this path, but for other…



  • I tried that.

    @Kereknjek said in MMM-ArduPort:

    Now, when running

    python arduport.py
    

    I get this:

    {"debug": "SerialPort shell started..."}
    {"debug": "Waiting Ardunio to connect on port..."}
    {"status": {"data": "connected", "name": "connect"}}
    {"status": {"data": "starting", "name": "setup"}}
    {"status": {"data": "started", "name": "setup"}}
    {"sensor": {"data": "0.02", "name": "Baterija"}}
    {"sensor": {"data": "-0.00", "name": "Struja"}}
    {"sensor": {"data": "0.00", "name": "Solarno"}}
    {"sensor": {"data": "-0.12", "name": "Panel"}}
    {"sensor": {"data": "-0.00", "name": "Inverter"}}
    {"sensor": {"data": "0.04", "name": "Baterija"}}
    {"sensor": {"data": "-0.00", "name": "Struja"}}
    {"sensor": {"data": "0.00", "name": "Solarno"}}
    


  • @Kereknjek that looks good…

    looks at the MMM-Arduino module, it shows debugging info on the developers window

    ctrl-shift-i on the keyboard, select the tab labeled ‘console’

    you can filter out other modules messages by putting part of the module name in the filter field

    ardu

    also, have to set developerMode:true in the module config.js section

    		    if (self.config.developerMode) {
    			      var date = new Date();
    			      var time = date.getHours() + ":" + date.getMinutes() + ":" + date.getSeconds();
    			      message = self.name + ": (" + self.data.index + ")(" + time + ") " + message;
    		    } else { message = self.name + ": " + message; }
    		    switch (type) {
    			  case "error": Log.error(this.logPrefix + message); break;
    			  case "warn": Log.warn(this.logPrefix + message); break;
    			  case "info": Log.info(this.logPrefix + message); break;
    			  case "dev": if (self.config.developerMode) { Log.log(this.logPrefix + message); } break;
    			  default: Log.log(this.logPrefix + message);
    		    }
    

Log in to reply