MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

New screen after configuring MM --> can't see edges



  • Hi,
    for installing and configuring my MM I used an old PC monitor. After that I plugged in my monitor for the mirror, rotated it and wanted to put it on the wall, but… now I have the problem that the edge on the bottom and on the right side is missing. So not everything that is in the mirror, is shown on the screen.
    Any solutions for such a problem? I just don’t want to the complete installing again. 😞
    Thanks for any help.



  • @iamthat79 i think u can set the resolution in the /boot/config.txt like you did the rotation angle…

    search google on raspberry pi rotate screen



  • I have already tried to do that. Here are the lines of my config.txt for that purpose. Any mistakes in there?
    hdmi_force_hotplug=1
    hdmi_group=2
    hdmi_group=86
    display_rotate=3



  • I have also tried to find out the actual resolution with & /opt/vc/bin/tvservice -s aand that’s 1920x1080. Maybe any chance to tell the pi to somehow reset the input of the hdmi port?



  • @iamthat79

    To change the resolution, run the command sudo raspi-config , navigate to Advanced Options > Resolution, and choose an option. Tells your Pi an HDMI display is attached. See the Raspberry Pi documentation for more hdmi_mode options, and information on /boot/config.txt in general.

    hdmi_group=2
    hdmi_group=86

    you have two hdmi_group statements

    https://www.raspberrypi.org/documentation/configuration/config-txt/video.md

    u have exhausted my knowledge here… others have done this, a search here might help



  • Don’t change the resolution, change the overscan setting in /boot/config.txt.

    In your case I assume you will have to play with
    overscan_right
    and
    overscan_bottom

    hope it helps, good luck!


Log in to reply