MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Unable to install dependencies



  • When I try to use

    bash -c "$(curl -sL https://raw.githubusercontent.com/sdetweil/MagicMirror_scripts/master/raspberry.sh)"
    

    The install takes maybe 2 seconds but it says install is complete, however I did not include the first $. If I do include this, it says that it doesn’t understand it. The MagicMirror folder is no where on my raspberrypi. As a result I tried to use

    $ sudo apt install python3 python3-pip -y && \
          git clone https://github.com/Bee-Mar/mmpm.git && \
          cd mmpm && \
          make && \
          echo "export PATH=$PATH:$HOME/.local/bin" >> $HOME/.bashrc && \
          source ~/.bashrc
    

    And afterwards do

    mmpm -M
    

    By using this method of installing it actually takes some time for MagicMirror to install, which seems a bit more reasonable. However, at the end of the installation it tells me that it is unable to install dependencies. It also says this is not a problem with npm, but rather that nodejs is out of date. It seems to actually be out of date because by doing

    nodejs -v
    

    It tells me that the version is v10.15.2 . So then I decided ill try to update nodejs by doing

    curl -sL https://deb.nodesource.com/setup_13.x | sudo -E bash -
    

    The result of this is

    ## Installing the NodeSource Node.js 13.x repo...
    
    
    ## Populating apt-get cache...
    
    + apt-get update
    Get:1 http://archive.raspberrypi.org/debian buster InRelease [25.1 kB]
    Get:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
    Reading package lists... Done                                         
    E: Release file for http://archive.raspberrypi.org/debian/dists/buster/InRelease is not valid yet (invalid for another 7d 17h 8min 13s). Updates for this repository will not be applied.
    E: Release file for http://raspbian.raspberrypi.org/raspbian/dists/buster/InRelease is not valid yet (invalid for another 10d 2h 29min 48s). Updates for this repository will not be applied.
    Error executing command, exiting
    

    As a result I cannot update nodejs to the proper version. I have tried deleting the MagicMirror folder and redoing all of this with no success and the same results. I don’t know if this is would be a contributing factor but I have been doing this through VNC. I don’t have my own USB keyboard so I borrowed a friends to setup VNC and now I just control everything through my laptop.



  • @nathan-joslin I forgot to mention that I am using a 64gb micro sd on a Pi3. Before writing the image I reformatted the sd to FAT32. I read about other issues and some people say that their issues have been solved by using a different sd, could this be similar?



  • @nathan-joslin I don’t know. Can u show me the ~/install.log



  • @sdetweil

    install starting  - Thu Feb 13 15:20:04 EST 2020
    installing on armv7l processor system
    the os is Distributor ID: Raspbian Description: Raspbian GNU/Linux 10 (buster) Release: 10 Codename: buster
    Updating packages ...
    Get:1 http://archive.raspberrypi.org/debian buster InRelease [25.1 kB] Get:2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB] Reading package lists... E: Release file for http://archive.raspberrypi.org/debian/dists/buster/InRelease is not valid yet (invalid for another 7d 17h 12min 50s). Updates for this repository will not be applied. E: Release file for http://raspbian.raspberrypi.org/raspbian/dists/buster/InRelease is not valid yet (invalid for another 10d 2h 34min 25s). Updates for this repository will not be applied.
    apt-get update  completed ok
    apt upgrade result =rc=0 Reading package lists...
    Building dependency tree...
    Reading state information...
    Calculating upgrade...
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Installing helper tools ...
    Check current Node installation ...
    Node currently installed. Checking version number.
    Minimum Node version: v10.1.0
    Installed Node version: v10.15.2
    No Node.js upgrade necessary.
    Check current NPM installation ...
    NPM currently installed. Checking version number.
    Minimum npm version: V6.0.0
    Installed npm version: V5.8.0
    npm should be upgraded.
    Installing npm ...
    Reading package lists...
    Building dependency tree...
    Reading state information...
    npm is already the newest version (5.8.0+ds6-4).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    upgrading npm to latest
    npm installation Done! version=V5.8.0
    Cloning MagicMirror ...
    Cloning MagicMirror Done!
    Installing dependencies ...
    Unable to install dependencies!
    


  • @nathan-joslin wow…

    If you do npm install in the MagicMirror folder. What other output do u get?



  • @sdetweil

    pi@raspberrypi:~ $ mmpm -M
    MagicMirror directory not found. Installing MagicMirror...
    
    $$\      $$\                     $$\           $$\      $$\ $$\                                          $$$$$$\
    $$$\    $$$ |                    \__|          $$$\    $$$ |\__|                                        $$  __$$\
    $$$$\  $$$$ | $$$$$$\   $$$$$$\  $$\  $$$$$$$\ $$$$\  $$$$ |$$\  $$$$$$\   $$$$$$\   $$$$$$\   $$$$$$\  \__/  $$ |
    $$\$$\$$ $$ | \____$$\ $$  __$$\ $$ |$$  _____|$$\$$\$$ $$ |$$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  __$$\  $$$$$$  |
    $$ \$$$  $$ | $$$$$$$ |$$ /  $$ |$$ |$$ /      $$ \$$$  $$ |$$ |$$ |  \__|$$ |  \__|$$ /  $$ |$$ |  \__|$$  ____/
    $$ |\$  /$$ |$$  __$$ |$$ |  $$ |$$ |$$ |      $$ |\$  /$$ |$$ |$$ |      $$ |      $$ |  $$ |$$ |      $$ |
    $$ | \_/ $$ |\$$$$$$$ |\$$$$$$$ |$$ |\$$$$$$$\ $$ | \_/ $$ |$$ |$$ |      $$ |      \$$$$$$  |$$ |      $$$$$$$$\
    \__|     \__| \_______| \____$$ |\__| \_______|\__|     \__|\__|\__|      \__|       \______/ \__|      \________|
                           $$\   $$ |
                           \$$$$$$  |
                            \______/
    
    install log being saved to /home/pi/install.log
    Updating packages ...
    Installing helper tools ...
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    build-essential is already the newest version (12.6).
    curl is already the newest version (7.64.0-4).
    git is already the newest version (1:2.20.1-2+deb10u1).
    unzip is already the newest version (6.0-23+deb10u1).
    wget is already the newest version (1.20.1-1.1).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Check current Node installation ...
    Node currently installed. Checking version number.
    Minimum Node version: v10.1.0
    Installed Node version: v10.15.2
    No Node.js upgrade necessary.
    Check current NPM installation ...
    NPM currently installed. Checking version number.
    Minimum npm version: V6.0.0
    Installed npm version: V5.8.0
    npm should be upgraded.
    Installing npm ...
    npm WARN npm npm does not support Node.js v10.15.2
    npm WARN npm You should probably upgrade to a newer version of node as we
    npm WARN npm can't make any promises that npm will work with this version.
    npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8, 9.
    npm WARN npm You can find the latest version at https://nodejs.org/
    npm ERR! code CERT_NOT_YET_VALID
    npm ERR! errno CERT_NOT_YET_VALID
    npm ERR! request to https://registry.npmjs.org/npm failed, reason: certificate is not yet valid
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /root/.npm/_logs/2020-02-13T20_21_42_189Z-debug.log
    npm installation Done! version=V5.8.0
    Cloning MagicMirror ...
    Cloning into 'MagicMirror'...
    remote: Enumerating objects: 331, done.
    remote: Counting objects: 100% (331/331), done.
    remote: Compressing objects: 100% (295/295), done.
    remote: Total 331 (delta 42), reused 194 (delta 23), pack-reused 0
    Receiving objects: 100% (331/331), 676.44 KiB | 105.00 KiB/s, done.
    Resolving deltas: 100% (42/42), done.
    Cloning MagicMirror Done!
    Installing dependencies ...
    npm WARN npm npm does not support Node.js v10.15.2
    npm WARN npm You should probably upgrade to a newer version of node as we
    npm WARN npm can't make any promises that npm will work with this version.
    npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8, 9.
    npm WARN npm You can find the latest version at https://nodejs.org/
    npm ERR! code CERT_NOT_YET_VALID
    npm ERR! errno CERT_NOT_YET_VALID
    npm ERR! request to https://registry.npmjs.org/feedme failed, reason: certificate is not yet valid
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/pi/.npm/_logs/2020-02-13T20_22_17_662Z-debug.log
    Unable to install dependencies!
    pi@raspberrypi:~ $ 
    

    Not sure if this helps either, I just deleted the MagicMirror folder before trying again.



  • @sdetweil

    pi@raspberrypi:~/MagicMirror $ npm install
    npm WARN npm npm does not support Node.js v10.15.2
    npm WARN npm You should probably upgrade to a newer version of node as we
    npm WARN npm can't make any promises that npm will work with this version.
    npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8, 9.
    npm WARN npm You can find the latest version at https://nodejs.org/
    npm ERR! code CERT_NOT_YET_VALID
    npm ERR! errno CERT_NOT_YET_VALID
    npm ERR! request to https://registry.npmjs.org/iconv-lite failed, reason: certificate is not yet valid
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/pi/.npm/_logs/2020-02-13T20_26_05_452Z-debug.log
    pi@raspberrypi:~/MagicMirror $ 
    

    Sorry I didn’t see your response, here is npm install



  • @nathan-joslin that CERT NOT VALID is a real problem…

    Will have to research



  • @sdetweil Why did your installation script not work? Tonight I may have time to delete the MagicMirror folder and use your script and show you what that says.



  • @nathan-joslin one suggestion for the cert error is to insure your system time is set correctly.

    My script is the same as before, and fails if npm install fails

    My script shows the same error, see line 5 of the log. Looks like the system date is in the past


Log in to reply