MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

PIR sensor does not switch on monitor



  • Hello,
    I have configured and connected the PIR sensor exactly as described in this explanation from Hardwarepoint (https://hardwarepoint.net/2017/06/diy-smart-mirror/4/). The sensor also worked until a few weeks ago. Since a few weeks the monitor does not switch off.

    Today I could finally take care of the problem and went through the installation steps again. Everything looks like it should be. It worked before. After a reboot, the SmartMirror also starts. And now after about 60 seconds the monitor switched off! But now, the monitor does not switch on when I move in front of it! It stays black. In a browser (Port 8080) I can see the MM. This means that the software is running, but the monitor does not turn on.

    The status displays the following

    pi@raspberrypi:~ $ sudo systemctl status pir.service
    ● pir.service - Display timeout PIR daemon
    Loaded: loaded (/etc/systemd/system/pir.service; enabled; vendor preset: enab
    Active: active (running) since Wed 2020-03-18 09:01:51 CET; 2h 39min ago
    Main PID: 1782 (python)
    Tasks: 2 (limit: 2200)
    Memory: 2.2M
    CGroup: /system.slice/pir.service
    └─1782 python /usr/local/sbin/pir

    Mar 18 09:01:51 raspberrypi systemd[1]: Started Display timeout PIR daemon.
    Mar 18 09:01:52 raspberrypi pir[1782]: display_power=1
    Mar 18 09:02:51 raspberrypi pir [1782]: display_power=0

    It would be really great if someone could help me.

    Thanks in advance.
    Klinge


Log in to reply