MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-Remote-Control GET Error



  • Hi there! Thank you for taking the time to read this.
    I have been trying to get my MMM-Remote-Control module up and running for some time now, but I inevitably reach the same wall every time I try to install it. The first time I tried to install the module, I used the auto install script and the second time I tried to install the module I did it manually. I have checked that the address is “0.0.0.0” and that my IP is included on the whitelist. I have included versions of the IP address both with a preceding “::ffff:” and without to be safe. In config.js, I have tried to simplify the configuration as much as possible, this is what I currently have:

    		{
    			module: 'MMM-Remote-Control',
    			position: 'bottom_left',
    		},
    

    I previously had a more complex config with a ‘config’ section, but I took that away to make it as simple as possible.
    I can successfully reach remote.html on my laptop, but immediately upon loading the developer console starts giving me GET errors. Here is a picture of the exact error that continuously is given:
    Screen Shot 2020-05-02 at 12.40.35 PM.png

    I would really appreciate any suggestions that anyone has as I would love to get this module up and running.

    Best,
    Jack





  • @sdetweil Hi Sam, thank you for the quick response. I updated ~/MagicMirror/js/socket.js with the specified code but to no avail. The issue still persists. The only effect of the code change seems to be that the pictures beside the buttons on the remote control have disappeared.
    Jack

    NOTE: The fix centers around updating the code in socketclient.js NOT socket.js.



  • @jmwyds hm… everyone else using that gets remote-control to work on 2.11



  • I followed the developer console to the line where the error is occurring and I have included that line here:Screen Shot 2020-05-02 at 12.53.08 PM.png



  • @jmwyds show the console tab, that source thing is a side effect of the real error



  • @sdetweil Sam, if I revert remote-control to an earlier version, would that be a plausible fix? Also, I included the console tab in the original post. Please let me know if there is something else that could help.



  • @jmwyds its not a remote-control problem, its a MM problem, which is why you have to fix the MM file



  • @sdetweil Sam, I just want to make sure that I got your first tip correct. Am I supposed to replace the code in socket.js or socketclient.js? The code from the reference post looks more like socketclient.js but I noticed that you originally said socket.js



  • @jmwyds Sam, I replaced the code in socketclient.js rather than socket.js after reading that post that you linked to more fully and now the error has stopped popping up! Thanks for your help! I just have to figure out how to get the remote-control pictures back on the buttons and I am good to go:)