MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Remote control



  • When i add this to my config my mirror stops working soon as i delete it starts again

    if i put my ip addy in for the pi with ports 8080 into my phone i can see the mirror but no remote control options where am i going wrong please

    {
    module: ‘MMM-Remote-Control’
    // uncomment the following line to show the URL of the remote control on the mirror
    , position: ‘bottom_left’
    // you can hide this module afterwards from the remote control itself
    config: {
    customCommand: {}, // Optional, See “Using Custom Commands” below
    customMenu: “custom_menu.json”, // Optional, See “Custom Menu Items” below
    showModuleApiMenu: true, // Optional, Enable the Module Controls menu
    apiKey: “”, // Optional, See API/README.md for details
    }
    },
    

    Only thing i have working with my pi is kodi and thats on a spare i am a total NOOB and in need of a lot of help



  • @hawkeye I dont use this module, but it looks like you have , position: ‘bottom_left’ You need to remove the comma at start of line.



  • i tried that still no joy

    what i want to do is to be able to add and remove modules from my phone and having no luck



  • @hawkeye u need a comma at the end of each line… the one at the front is for the line before, but after has no ,

    also, check the actual text in config.js, the quote marcks, both single and double are the wrong kind, they are the word processing app type… (as they lean)… u need the text kind, straight up and down

    {
    	module: 'MMM-Remote-Control',
    	position: 'bottom_left',
    	config: {
    		customCommand: {}, 		 // Optional, See "Using Custom Commands" below
    		customMenu: "custom_menu.json", // Optional, See "Custom Menu Items" below
    		showModuleApiMenu: true, // Optional, Enable the Module Controls menu
    		apiKey: "", 			 // Optional, See API/README.md for details
    	}
    },
    


  • This post is deleted!


  • @sdetweil said in Remote control:

    {
    module: ‘MMM-Remote-Control’,
    position: ‘bottom_left’,
    config: {
    customCommand: {}, // Optional, See “Using Custom Commands” below
    customMenu: “custom_menu.json”, // Optional, See “Custom Menu Items” below
    showModuleApiMenu: true, // Optional, Enable the Module Controls menu
    apiKey: “”, // Optional, See API/README.md for details
    }
    },

    You rock that fixed that part now i just need to make it show modules so i can turn them off



  • @hawkeye there is a bug on 2.11 tgat stops remote control from working.

    search the forum for the fix



  • @sdetweil yeah I’m no programmer

    i need an idiots guide to things



  • @hawkeye you are replacing one file, no programming required



  • @sdetweil you have been a grate help so far and yes i know i am annoying but i cant find what i am to do


Log in to reply