MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Changing IP adresses



  • I had to change my wireless router. When I dd and rebooted the MagicMirror it can’t see the new wireless system.
    It was working fine with the old routing information when I set it up initially. What do I have to do to get it back on the new address? I tried adding the new address for the new wireless address to the config.js file as described, but it did no good. It still doesn’t see it… Any suggestions?
    Thanks all of you with smarts out there
    Dennis N6NG



  • @N6NG there should be nothing about the real network in config.js

    address:"0.0.0.0",
    ipWhitelist:[],
    

    did the SSID of the network change? use the network widget on the raspi desktop, next to the date/time, top right.

    to minimize mm, in case it’s up, alt-spacebar, n



  • Thanks… I’ll let you know…
    Dennis



  • That didn’t help… And yes the SSID changed
    Dennis


  • Project Sponsor

    I’m a little confused. Is your Rpi on your wireless network at all? Can you use the web browser on your Pi to pull up a website?

    It sounds like your Pi isn’t playing well with your new router. If you minimize the MM interface and click on the Wifi symbol in the top right of your mirror, you should be able to select the new SSID and enter the password to get onto the network. Did your Wifi network password also change?



  • No… I can’t connect to any web pages… It just say it can’t find the page I requested…
    Dennis



  • Doesn’t show the Ssid box in the corner… Just the bluetooth keyboard and the sound speaker and the time. which is incorrect…



  • @N6NG go to the menu, upper left, then preferences, network



  • Doesn’t show the Network option … Just the Raspberry Pi Configuration. When I choose; that option, I have an Interfaces option. I pick that one and have several options to enable and disable. One of which is SSH which I enable and it doesn’t do me any good.
    I’m running the Debian version…



  • @N6NG open terminal on pi, (ctrl-alt-t) and then sudo raspi-config, network options
    Screenshot at 2020-08-26 12-55-35.png


Log in to reply