MagicMirror² v2.12.0 is available! For more information about this release, check out this topic.

Failed to install dependencies, while trying to install MM2



  • I tried different methods of installing MM, still without succes.
    See below the response i’m getting

    pi@raspberry:~ $ npm install

    /usr/local/lib/node_modules/npm/bin/npm-cli.js:87
    let notifier = require(‘update-notifier’)({pkg})
    ^^^^^^^^
    SyntaxError: Unexpected identifier
    at Module._compile (module.js:439:25)
    at Object.Module._extensions…js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)
    at node.js:906:3

    Anyone any id what to do?

    Re: Failed to install dependencies RPI3 B+


  • Project Sponsor

    bash -c  "$(curl -sL https://raw.githubusercontent.com/sdetweil/MagicMirror_scripts/master/raspberry.sh)"
    

    Delete MM folder or rename it and run this install script from @sdetweil



  • @MaikH1 delete the MagicMirror folder and run the installation script from here
    https://github.com/sdetweil/MagicMirror_scripts



  • Thanks for the help, really appreciate it.

    That’s what I did, this is the whole message:

    pi@raspberry:~ $ bash -c “$(curl -sL https://raw.githubusercontent.com/sdetweil/MagicMirror_scripts/master/raspberry.sh)”

    $$\ $$\ $$\ $$\ $$\ $$\ $$$$$$
    $$$\ $$$ | _| $$$\ $$$ |_| $$ $$
    $$$$\ $$$$ | $$$$$$\ $$$$$$\ $$\ $$$$$$$\ $$$$\ $$$$ |$$\ $$$$$$\ $$$$$$\ $$$$$$\ $$$$$$\ _/ $$ |
    $$$$$$ $$ | _
    $$\ $$ $$\ $$ |$$ |$$$$$$ $$ |$$ |$$ $$\ $$ $$\ $$ $$\ $$ $$\ $$$$$$ |
    $$ $$$ $$ | $$$$$$$ |$$ / $$ |$$ |$$ / $$ $$$ $$ |$$ |$$ | _|$$ | _|$$ / $$ |$$ | _|$$ /
    $$ |$ /$$ |$$ __$$ |$$ | $$ |$$ |$$ | $$ |$ /$$ |$$ |$$ | $$ | $$ | $$ |$$ | $$ |
    $$ | _/ $$ |$$$$$$$ |$$$$$$$ |$$ |$$$$$$$\ $$ | _/ $$ |$$ |$$ | $$ | $$$$$$ |$$ | $$$$$$$$
    _
    | _
    | _
    | _
    $$ |_| _
    |_| _|_|_| _| _
    _/ _| ________|
    $$\ $$ |
    $$$$$$ |
    ______/

    install log being saved to /home/pi/install.log
    this appears not to be a Raspberry Pi 2, 3 or 4, do you want to continue installation (y/N)?y
    Updating packages …
    Installing helper tools …
    Check current Node installation …
    Node currently installed. Checking version number.
    Minimum Node version: v10.1.0
    Installed Node version: v0.10.29
    Node should be upgraded.
    Installing Node.js …
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    nodejs is already the newest version.
    The following package was automatically installed and is no longer required:
    libuuid-perl
    Use ‘apt-get autoremove’ to remove it.
    0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
    node version is
    Node.js installation Done! version=v0.10.29
    Check current NPM installation …
    NPM currently installed. Checking version number.

    /usr/local/lib/node_modules/npm/bin/npm-cli.js:87
    let notifier = require(‘update-notifier’)({pkg})
    ^^^^^^^^
    SyntaxError: Unexpected identifier
    at Module._compile (module.js:439:25)
    at Object.Module._extensions…js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)
    at node.js:906:3
    Minimum npm version: V6.0.0
    Installed npm version: V
    npm should be upgraded.
    Installing npm …

    /usr/local/lib/node_modules/npm/bin/npm-cli.js:87
    let notifier = require(‘update-notifier’)({pkg})
    ^^^^^^^^
    SyntaxError: Unexpected identifier
    at Module._compile (module.js:439:25)
    at Object.Module._extensions…js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)
    at node.js:906:3

    /usr/local/lib/node_modules/npm/bin/npm-cli.js:87
    let notifier = require(‘update-notifier’)({pkg})
    ^^^^^^^^
    SyntaxError: Unexpected identifier
    at Module._compile (module.js:439:25)
    at Object.Module._extensions…js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)
    at node.js:906:3
    npm installation Done! version=V
    Cloning MagicMirror …
    Cloning into ‘MagicMirror’…
    remote: Enumerating objects: 284, done.
    remote: Counting objects: 100% (284/284), done.
    remote: Compressing objects: 100% (223/223), done.
    remote: Total 284 (delta 53), reused 136 (delta 48), pack-reused 0
    Receiving objects: 100% (284/284), 386.02 KiB | 0 bytes/s, done.
    Resolving deltas: 100% (53/53), done.
    Checking connectivity… done.
    Cloning MagicMirror Done!
    Installing dependencies …

    /usr/local/lib/node_modules/npm/bin/npm-cli.js:87
    let notifier = require(‘update-notifier’)({pkg})
    ^^^^^^^^
    SyntaxError: Unexpected identifier
    at Module._compile (module.js:439:25)
    at Object.Module._extensions…js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)
    at node.js:906:3
    Unable to install dependencies!

    I’m kinda lost here, not sure where the error comes from.


  • Project Sponsor

    Use the below raspberry imager and do a fresh install of raspbian and then try the installer from Sam.

    https://www.raspberrypi.org/downloads/



  • @swvalenti nd use the full desktop buster image



  • So not the Raspberry Pi OS (32-bit), but the Raspberry Pi OS Full (32-bit)? ,
    I’ll try that thank you, last time I used the first one.

    I’ll be back :), hopefully with good news.



  • @MaikH1 correct.



  • Hmm still no good news.
    For some reason when I make the image USB with the Full image it isn’t bootable.
    I tried it with three different USB sticks and wrote the sticks from two different pc’s, but when I try booting/installing from this USB it won’t start. It just gives me the message no bootable device.

    When I switch to the old USB (with the Raspberry Pi OS (32-bit), it works immediately.
    Any ideas what I’m doing wrong?



  • @MaikH1 make sure u didn’t get the 64 bit version.

    should be the 1st entry here
    https://www.raspberrypi.org/downloads/raspberry-pi-os/


Log in to reply