MagicMirror² v2.7.0 is available! For more information about this release, check out this topic.

Calendar Module - Unable to load Facebook Birthdays


  • Moderator

    Got home, did a full reset on my dev tree, added the above code piece and this is what I get. Waiting on more confirmation from others before I push this up to the main repo.

    0_1464390609193_bdays.png



  • @KirAsh4 said in Calendar Module - Unable to load Facebook Birthdays:

    Ok, I need some testers … this is working for me with a small change in our fetcher code. So, for those willing to try, please following these steps:

    Step 1
    Navigate to the 'MagicMirror/modules/default/calendar/' folder

    Step 2
    Open the 'calendarfetcher.js' file in your favorite editor and look for the following line and delete it:

    ical.fromURL(url, {}, function(err, data) {
    

    Step 3
    After deleting that line, in its place you’re going to paste in the following snippet of code:

        var opts = {
            headers: {
                'User-Agent': 'Mozilla/5.0 (Node.js 6.0.0) MagicMirror/2.0 (https://github.com/MichMich/MagicMirror)'
            }
        }
        ical.fromURL(url, opts, function(err, data) {
    

    Please note that very last line, it’s almost identical to the one you deleted. Only one piece changed and you must put that line in as modified above!

    Step 4
    Save and close the file, and relaunch your MM process.

    Step 5
    Report back to me.

    On my setup, it’s working. I’m getting this in my calendar now. (The names you see are birthdays, I simply have a filter to remove 's birthday' form the string that Facebook returns.)

    Made these changes, we are good! Works now 🕶 Thank you so much for all the help.



  • Doesn’t seem to fix it for me 😕


  • Moderator

    @andy952, can you send me your calendar link privately and I’ll test it out on my system, see if I find any errors.



  • this fixes the problem for me as well.



  • Awesome! Facebook birthdays and events are working again 🙂
    Thanks for your help.


  • Moderator

    With the majority of you saying it’s working with the above change, I went ahead and made a pull request against the branch. When @MichMich has time, he’ll review and merge. I’m still waiting to hear from @andy952 to see if there still is a problem.


  • Admin

    @KirAsh4 Just got back from my holiday. Almost ready to merge your PR. One small issue: see GitHub.