Update checker Git dependency?



  • As I wrote about some here, it seems that the update checker has a Git dependency. (I haven’t looked at the code that carefully, please forgive me if that assumption is wrong.)

    Normally this would not be a problem if you follow the install directions directly as they specify running a git clone command so naturally you must have Git. But I did it using the GitHub Desktop option, and someone could certainly use the Download As ZIP option from GitHub.com too.

    I don’t really care too much since they program still runs and I have figured out how to get rid of the exception that it causes. But I thought I might pose two questions:

    1. Should there be a note in the manual install instructions that Git on your path is a requirement?
    2. Should there be a Git dependency in the first place for checking for updates?

Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.