MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-Pages and Alexa



  • I have a problem with MMM-Pages (only have MMM-Pages installed) and Alexa
    I’ve already managed to change the 2 sides see code:

    {
            module: 'MMM-pages',
            config: {
            animationTime: 0,
    		rotationTime: 10000,
    		rotationDelay: 0,
    		pages: 2,
    		         modules:
                        [[ "calendar", "weatherforecast"],
                         [ "MMM-RAIN-RADAR" ]],
                    fixed: ["clock", "MMM-OpenmapWeather", "MMM-page-indicator"],
             }        
            },
    		
    
    

    Now I would like to switch the pages on or switch over with Alexa see code:

    {
                module: 'MMM-AlexaControl',
                position: 'bottom_left',
                config:{
                    image: false,
                    pm2ProcessName: "mm",
                    refresh: true,
                    restart: true,
                    reboot: false,
                    monitorToggle: true,
                    vcgencmd: 'vcgencmd',
                    deviceName: "Spiegel",
                    startPort: 12000,
                    notifications: [
        							  {
           			 					name: 'Radar',
           			    			    port: 11101,
            					        OnOff: true,
            		 					notification: [["SHOW_RADAR", null],["HIDE_RADAR", null]]
                 						},
                 						{
            							name: 'Seite eins',
           								port: 11102,
            							OnOff: true,
            							notification: ["PAGE_CHANGED", 0]
            							},
            							{
            							name: 'Seite zwei',
           								port: 11103,
            							OnOff: true,
            							notification: ["PAGE_CHANGED", 1]
            							}
    				]
              
             }
           	 },	
          
    
    

    Unfortunately that doesn’t work.
    Now the question where is my mistake
    P.S. Alexa finds my devices



  • @radioman open the developers window, ctrl-shift-i on the keyboard then select the console tab and look for the notification being sent

    u can filter on the module name, part.in the filter field, Alexa for example.
    and u are saying (All in your language)

    Alexa turn on Seite eins



  • OK
    is the code correct in terms of reasoning
    Because I cannot switch pages in the Alexa app



  • @radioman I don’t know. not my module. did the notification get sent? use debug to see

    radar works

    are u using the right command?

    do u need two notifications? one for on and one for off?



  • Unfortunately, I’m not the kind of programmer that debugging is concerned
    But switching radar is possible in the Alexa app and by voice



  • @radioman open the console and watch.

    look at the console where u start mm,

    npm start or pm2 logs --lines=???
    ??? is a number 15 default

    gotta learn



  • I also use the MMM remote control module.
    The Pages tab is empty on the smartphone or in the browser



  • @radioman sorry, don’t use pages



  • I will try tommorow, now its time for me to go to bed


  • Module Developer

    @radioman Hi. You made one mistake in the configuration for your page devices. You set OnOff to true. If it’s set to true you can send different notifications for on and off. So you have to set it to false for this two devices. Your config looks then like this:

    {
        module: 'MMM-AlexaControl',
        position: 'bottom_left',
        config:{
            image: false,
            pm2ProcessName: "mm",
            refresh: true,
            restart: true,
            reboot: false,
            monitorToggle: true,
            vcgencmd: 'vcgencmd',
            deviceName: "Spiegel",
            startPort: 12000,
            notifications: [
                                {
                                    name: 'Radar',
                                    port: 11101,
                                    OnOff: true,
                                    notification: [["SHOW_RADAR", null],["HIDE_RADAR", null]]
                                },
                                {
                                    name: 'Seite eins',
                                    port: 11102,
                                    OnOff: false,
                                    notification: ["PAGE_CHANGED", 0]
                                },
                                {
                                    name: 'Seite zwei',
                                    port: 11103,
                                    OnOff: false,
                                    notification: ["PAGE_CHANGED", 1]
                                }
                            ]
        }
    },
    

    Instead of this you could also use the pages option and set it to the number of pages you have. You can then change the names in the Alexa app.


Log in to reply