MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

Cant Start MMPM GUI



  • Hello,

    first of all: I have absolutely 0 (and i mean it that way) programming experience. I have written maybe a few lines of html when I did some Age of Empires Scripts but thats it.

    So far I managed to setup Raspbian 10 (Buster) on my RP4, downloaded MagicMirror2 according to the instructions. Then I upgraded to Python 3.7.3 with PM2 (according to instructions and works)
    and then I installed MMPM (according to instructions)

    Current status:
    Magic Mirror is running. I have it on autostart when the RP4 boots. PM2 lets me use commands to start/stop etc.
    MMPM is running and I can access the CLI and use it as well as download/install modules.

    However whenever I give the CLI the mmpm open --gui command it opens the browser with a Bad Gateway result.

    I have been fooling around with the environment variables and at the moment they are set in this way:

    The MagicMirror config shows 192.168.1.11:8080 as the Mirrors Urls.
    In the env i have the same Url 192.168.1.11:8080
    and for the PM2 Process i have PM2 (however in the examples of the env settings the people who have pm2 write MagicMirro which really confuses me since i have a PM2 process but not a MagicMirror process)

    Can anyone help we with figuring out why the MMPM GUI doesnt work?
    I am happy to supply any information needed 🙂

    Thanks in advance and may you all have a great day!



  • @Zar that url should be http://192.168.1.11:8080

    right?

    the desktop browser will add http://
    if it is missing, programs are not so nice

    the thing you started MagicMirror with is the MagicMirror process.



  • You were absolutely right about the http

    I changed the process now in the env file to MagicMirror. However now there is no connection between mmpm and mm anymore.

    Conclusion: now i have the gui but i mmpm cannot access active modules anymore. i tried switching the process in the env back to pm2 but that doesnt help either.



  • @Zar I would look at the mmpm wiki
    https://github.com/Bee-Mar/mmpm/wiki/Command-Line-Options

    and open in issue if u need more help



  • I did look at the wiki but none of the mmpm commands help with loosing the connection. The right env in this case is pm2 as i figured out by trying under which circumstances mmpm can control mm.

    However since until now not a single module could be loaded i will flash the SD card and start from scratch.



  • @sdetweil seems the hard way, vs asking the MMPM author



  • Well mmpm was not the only thing not working 😉

    I will try to install Magic Mirror through the MMPM commands this time. Maybe that helps.



  • @Zar i would just use my scripts…

    https://github.com/sdetweil/MagicMirror_scripts



  • Please do me and future askers a favor and dont tell them to use your script. Thats the second flash of the raspberrie now…

    Your script basically makes it impossible to stop MM because it just restarts npm and PM2 as well as MM every single time you try to shut it down.



  • @Zar pm2’s job is to restart , you can always minimize MM (alt-spacebar, n) and then use pm2 to stop,
    (alt-ctrl-t to open a terminal window)
    or use an ssh ssession to the pi and pm2 stop…

    or not accept pm2 during install … all kinds of ways to handle it…

    alt-spacebar, n to minimize is the same as for Windows on any app.


Log in to reply