MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

MMM-RadioDE will not play



  • Hello all,

    I have a Problem since two weeks that the module RadioDE will start and show the radiostation but will not play.

    a reinstall of this modul have not work and chance the station will not work too.

    I hope anyone can help me.

    Best regards

    Blackmirror



  • Hello,

    have noone a idea? Or a other simple radio module? But with no buttons. Only simple play a radiostream.

    Here my config.js

    {
            module: 'MMM-RadioDe',
            classes: 'Radio',
            position: 'bottom_left', // This can be any of the regions.
            config: {
                    // See 'Configuration options' for more information.
                    station: "hr3",
                    // can be obtained in embed section of station, e.g. http://ant$
                    api_key: "xxx",
                    autoplay: "true"
                    //optional,
                    //height:"92", // in pixel
                    //width:"360", // in pixel
            }
    },
    
    

    The error looks like a bad API, but the API is right.


  • Module Developer

    @Blackmirror Hi, if you like you can give a try to my radio module MMM-MplayerRadio. There are config options to hide most things and there is a autoplay feature.



  • Hello
    it’s works but after controlled with Notification, it will not more displayed. But this is not really a problem.

         module: 'MMM-Buttons',
    //                        classes: 'default everyone',
         config: {
        minShortPressTime: 20,
        bounceTimeout: 10,
                 buttons: [
                 {
                 pin: 10,
                 name: "Radio",
                 longPress: {
                          notification: "RADIO_STOP",
                        payload: "default"},
                 shortPress: {
                        notification: "RADIO_PLAY",
                        payload: "Radio"}},
            {
                pin: 11,
                name: "Tagesschau",
                longPress: {
                  notification: "BUTTON_PRESSED",
                  payload: true
                },
               shortPress: {
                  notification: "BUTTON_PRESSED",
                  payload: true
                }
            }
        ]
    }},
    
    {
            module: "MMM-MplayerRadio",
            classes: 'Radio',
            header: "Radio",
            position: 'bottom_left', // This can be any of the regions.
            config: {
                    //autoplay: 0,
                    stations: [
                                    {
                                    title: "hr3.de",
                                    url: "http://www.surfmusik.de/m3u/hr3-mitte,19472.m3u",
                                    logo: "https://upload.wikimedia.org/wikipedia/commons/thumb/e/e1/Hr3-Logo_2015.svg/240p$
                                    }
                            ],
                            showControls: false,
                            showVolControls: false
                    }
    },
    
    

    Thanks Blackmirror


  • Module Developer

    Hi,

    great if it works. You may want to add an “showStations: false,” to your config. The yellow radio symbol then will be displayed instead of showing the station logos. If you want the module to be invisible you can remove the position option. The module will be functional even if it is not displayed.


Log in to reply