MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

Getting Loss of Signal fault on large monitor.



  • I have a monitor in bedroom that is not being used so decided to build another display for bedroom.
    This new build will run for a while then the monitor will go to a default No Signal screensaver built in to monitor.
    I dug around and found some MagicMirror tutorial that seemed to address that problem. Ran through tutorial which seemed like it was somewhat out of date as it was dated 2016. I had already set up the MM to start automatically via pm2 prior to this and all was fine. but on that first reboot after doing the tutorial for screen blanking/screensaver the MM didn’t start and got a fullscreen terminal window with the text in a crazy small size/screen resolution.

    Re-Commented out line item “x-server-command=X .s O .dpms” in .conf file and everything seemed to return to normal including the loss of signal fault which never was resolved.

    Is there a more current rendition of tutorial to fix this problem?
    This tutorial was by KirAsh4 dated June 15th, 2016
    Like on step 3 or so it says it is addressing screensaver and screen blanking

    forum.magicmirror.builders/topic/236/complete-setup-tutorial/6



  • @ankonaskiff17 many monitors cannot handle signal off.

    I wrote my own screen off module which hides all the modules, not totally black. But decent.

    U can turn off the Screensaver, but then its always on. The screensaveroff script in my scripts will disable the screensaver.



  • What is causing that loss of signal to monitor? Right now monitor is showing loss of signal yet I am accessing Pi via VNC and it shows as if signal being sent to monitor.
    In other things I’ve done, if HDMI disconnected you can’t see the Pi.
    So I assume more of a monitor issue than a Pi issue.



  • @ankonaskiff17 do you use PIR? or have screen saver turned on?

    one of my old tvs would display that no signal panel after 10 minutes with the screen blanked by the screensaver



  • I just went through the TV settings and turned off several settings but it still turns off. I did make some forward progress in that now I can hit ALT on keyboard and MM image turns back on.
    The thing is, I think it is more related to signal flow on HDMI cable to TV. The other MM display I have has a live YouTube stream in iFrame so constant flow of data to monitor. It never cuts off. If I shutdown the MM software such that the Pi OS desktop is only thing on, then that monitor will go black too but click of mouse brings it back.



  • @ankonaskiff17 ok, that means Screensaver is still active.

    Use the screensaveroff script from my scripts site
    https://github.com/sdetweil/MagicMirror_scripts



  • I’ll do that here shortly, if needed, after I run a test.
    There is a screen blanking setting in the Pi’s preferences (I didn’t know about) that I just disabled and I’m checking monitor periodically. Looks like that is going to do the trick so far.



  • Turning off screen blanking appears to have resolved that issue.


Log in to reply