MagicMirror² v2.14.0 is available! For more information about this release, check out this topic.

MMM-LocalTemperature doesn't work :(



  • Hi guys,

    I’m trying to make a magic mirror as a school project. We are using a DHT-22 sensor to get local temperature and humidity but it doesn’t work. I’ve been working on it for 4 days now and I can’t find any solution 😞

    Here is my config.js and how i wired it

    130540251_1142119306191089_2675867096589592965_n.jpg

    Capture.PNG

    BTW : I have a python script on the py that reads datas from dht 22 soooo ://

    Thanks,

    Ipso



  • Update : I’ve tried other modules (dht-22 & DHT-22) but nothing changed 😕

    Python.png

    But my script still works so I was wondering if there’s a way to use it in a module ?

    I’m clearly a beginner so I somebody as any clue for me ://

    Thanks

    Ipso



  • Have you looked in the 3rd Party modules section? There are several DHT sensor modules in there you can use for reference, Just do text search on DHT



  • Hi

    I have the module working, but had to specify the pin scheme for it to work. It wouldn’t work for me without this config line.

    See below

                {
                        module: "MMM-LocalTemperature",
                        position: "top_right",
                        header: "Inside Temperature",
                        config: {
                                pinScheme: "WPI",
                                sensorPin: 0,
                                fontsize: "medium",
                                updateInterval: 1,
                                showTemperature: true,
                                showHumidity: true,
                                }
                },


  • @jimus888 Thanks for your answer, but still doesn’t work :!

    The module seems to load forever 😕

    I’ve tried apt-get update && apt-get full-upgrade but nothing seems to work 😕



  • @Ipsopedion said in MMM-LocalTemperature doesn’t work 😞:

    The module seems to load forever

    That means the default message was put up while the module is waiting for data… but hasn’t yet received it

    Can u should the output where u start magic mirror? Either the terminal window for npm start,
    Or if using pm2, the output of pm2 logs --lines=???, where ??? Is a number, defaults to 15


Log in to reply