MagicMirror² v2.5.0 is available! For more information about this release, check out this topic.

ZOOM /Scaling



  • So i tried the the default config/ zoom setting and dont seem to do anything i was wondering if some one could shed some light on the issue for me. ps im using a 47in tv and im trying to down scale the words as i made a Boo boo and cracked the edge of the screen



  • I also tried using the zoom setting yesterday, both in in the main configuration (under the ip address whitelist) and inside of various modules. I saw no change to the size of anything, and I tried values from 10.0 to 0.1. Not sure of the proper format, i used both zoom: ‘0.5’, and zoom: 0.5,.

    Not sure if it makes a difference but I am running mine serveronly on a Pi3 and viewing on a web page on a Pi0.



  • you can change it in css/custom.css file

     body {
     	zoom: 75%;
     }
    

    I didn’t find why the config file value is not taken in consideration. I assume something is overwriting this value.



  • I set the zoom on 0.25 for a test, this worked. But thats much to small… I want to set it back to 1.0, but this doesn’t work anymore. The font keeps small. Changing the css/custom.css doesnt work for me too. Any Idea?



  • Ok, got same problem…
    Connecting the keyboard and hitting Ctrl+0 to reset zoom seemed to work.
    Seems that zoom value is being cached somewhere…



  • Same issue here. It was fine before the latest update.



  • @nagaculun

    Try using @FredSWG fix above. The custom.css works great for me.



  • @Reotch2
    Can’t do that. I have 2 set of config; day and night.

    On day time, it would display all those weather, calendar, news feed and 3 clocks. Zoom is set to 2.
    On night time, it would only show 1 clock, with zoom set to 6.

    So the custom.css fix can’t be used or I have to create a separate custom.css.