Installation Error - Electron installer issue



  • Dear community,

    I’m trying to use the automatic installer on a new rasp pi 3, update jessie raspbian version ( no other packages installed ) but I’m getting the same error over and over again.
    The installation always fails at the point of post install of Electron ( see screenshot below )

    Cloning MagicMirror Done!

    module.js:442
        throw err;
        ^
    
    Error: Cannot find module '/root/MagicMirror/node_modules/electron-prebuilt/install.js'
        at Function.Module._resolveFilename (module.js:440:15)
        at Function.Module._load (module.js:388:25)
        at Function.Module.runMain (module.js:575:10)
        at startup (node.js:160:18)
        at node.js:456:3
    

    At the end, the installation stops with the following error:

    npm ERR! electron-prebuilt@1.2.1 postinstall: `node install.js`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the electron-prebuilt@1.2.1 postinstall script 'node install.js'.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the electron-prebuilt package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     node install.js
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR!     npm bugs electron-prebuilt
    npm ERR! Or if that isn't available, you can get their info via:
    npm ERR!     npm owner ls electron-prebuilt
    npm ERR! There is likely additional logging output above.
    

    Anyone some thoughts they want to share?
    Thanks


    Edit from admin: Please use Markdown on code snippets!



  • Same error on my side … I hoped to find a solution here but it looks like no one answered …



  • I have the same error - running it on a headless Pi3 (ie I Putty in from elsewhere and monitor the output from elsewhere too).
    I have been told that I should not run MM from the CLI, but rather that "The application needs to be started while the GUI-environment is running.’

    Can you please confirm if you are running ON THE PI directly or if you SSH’ed in?



  • @amanzimdwini

    I’m running directly on the PI !


  • Module Developer

    Hey there!

    You should not install MagicMirror as Root in the /root directory.

    check out this:
    https://forum.magicmirror.builders/topic/259/installing-mm2/10

    I think it is the same issue.

    @Bangee said in Installing MM2:

    as I c, you’ve installed your MagicMirror in the /root directory.
    I’m not sure if this is working so far.

    Try to install everything as pi and not as root in the /home/pi directory and let us know what happend.

    try whoami -> pi

    update your distribution with sudo apt-get update && sudo apt-get upgrade

    then cd /home/pi or only cd

    and install again: curl -sL https://raw.githubusercontent.com/MichMich/MagicMirror/master/installers/raspberry.sh | bash



  • @Bangee

    Thanks for your answer, I’m going to try that right now !


  • Module Developer

    how was it? :-)



  • @Corvis1984
    I found this one
    https://forum.magicmirror.builders/topic/236/complete-setup-tutorial/2
    and it worked like a charm… (and it it so detailed even I could not mess it up)

    On top of that, it is lean and made my WiFi FINALLY work too. Now all I need is the toaster attachment to my Pi

    Best of luck!



  • @Bangee

    Perfect ! I installed MM2 as PI user and it works now !

    Thanks for your help


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.