Lost resolution after reboot?!?



  • Hi there,
    my MagicMirror worked fine, until I had to rebbot the Pi for some reason.
    After rebooting the resolution is far too low. I use a Samsung Syncmaster 245B+ with FullHD.

    How can I fix this?

    Cheers
    KC


  • Moderator

    Hi. Was your display switched off during reboot? I had that with my tv and follow a small tutorial to save my display settings so the pi does not care if the display is on or off during boot



  • No, unfortunately the Monitor was turned on. I think there is sth wrong with the settings in /boot/config.txt
    But I can’t figure out, how to fix this.



  • So, here ist my /boot/config.txt:

    # For more options and information see
    # http://www.raspberrypi.org/documentation/configuration/config-txt.md
    # Some settings may impact device functionality. See link above for details
    
    # uncomment if you get no picture on HDMI for a default "safe" mode
    hdmi_safe=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_heiframebuffer_width=1080
    #framebuffer_height=1920
    #framebuffer_depth=32
    #framebuffer_ignore_alpha=1
    
    # uncomment if hdmi display is not detected and composite is being output
    hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    hdmi_group=2
    hdmi_mode=69
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    hdmi_drive=1
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=4
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800
    
    # Uncomment some or all of these to enable the optional hardware interfaces
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on
    
    # Uncomment this to enable the lirc-rpi module
    #dtoverlay=lirc-rpi
    
    # Additional overlays and parameters are documented /boot/overlays/README
    
    # Enable audio (loads snd_bcm2835)
    #dtparam=audio=on
    
    display_rotate=3
    avoid_warnings=1
    
    

    The Samsung Syncmaster 245plus has a native resolution of 1920x1200@60Hz.
    I think the hdmi_group an _mode settings are correct, but it still doesn’t work…
    What is wrong?



  • /opt/vc/bin/tvservice -s
    state 0x120006 [DVI DMT (4) RGB full 4:3], 640x480 @ 60.00Hz, progressive
    

    That is the resolution shown by the Raspi.

    Slowly I have the feeling like sitting at an Windows-Machine…


  • Moderator



  • /opt/vc/bin/tvservice -m CEA
    Group CEA has 2 modes:
               mode 4: 1280x720 @ 60Hz 16:9, clock:74MHz progressive 
               mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive 
    
    /opt/vc/bin/tvservice -m DMT
    Group DMT has 1 modes:
      (prefer) mode 4: 640x480 @ 60Hz 4:3, clock:25MHz progressive 
    

    The Mirror worked for mont without any issues…


  • Moderator

    @Kai-Christoph said in Lost resolution after reboot?!?:

    hdmi_group=2

    means "use DMT"
    hdmi_group=1 would use CEA

    So I would suggest finding out possible modes in CEA and set these in your config.txt



  • tvservice -d edid
    Nothing written!
    

    I tried this before…
    edid seems not to work.



  • Now I tried this, as mentioned here

    hdmi_cvt=1920 1200 60 5 0 0 1
    

    Nothing happened: The Raspi stucks on 640x480…


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.