MagicMirror² v2.13.0 is available! For more information about this release, check out this topic.

USB-Microphone TP6920

  • Project Sponsor Module Developer

    Hello guys,

    I bought myself an usb-microphone (TP6920). On my Laptop (Ubuntu 16.04) I can use it plug’n’play, but it’s not getting recognised on the Raspberry Pi 3.

    Any ideas what i can try?

    Thanks in advance

  • Moderator

    I have no experience with this specific microphone (or any other for that matter), but I would recommend starting to compare what the systems report when you plug them in. On your laptop, look at the systems log (often that’s '/var/log/messages' but may be different on ubuntu), plug the microphone in and watch the messages. Also check what 'lsusb' reports.

    now do the same on the raspberry pi, see what the system messages are when you plug in the microphone, and also check what 'lsusb' reports. If you discover it’s a driver issue, then you need to see what driver your laptop is using for the microphone, and see if it exists on the raspberry pi.

    Another possibility is that the rpi might not have the master audio mixer enabling the microphone. Unfortunately that’s more involved and something you’ll have to research on Google perhaps. Each hardware is different, but I’m sure others out there have purchased the same hardware.

  • Project Sponsor Module Developer

    Raspberry Pi

    Jun 8 21:13:10 raspberrypi kernel: [ 2437.370474] usb 1-1.4: new full-speed USB device number 7 using dwc_otg
    Jun 8 21:13:10 raspberrypi rsyslogd-2007: action ‘action 17’ suspended, next retry is Wed Jun 8 21:13:40 2016 [try ]
    Jun 8 21:13:10 raspberrypi kernel: [ 2437.500496] usb 1-1.4: New USB device found, idVendor=1130, idProduct=6920
    Jun 8 21:13:10 raspberrypi kernel: [ 2437.500521] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    Jun 8 21:13:10 raspberrypi kernel: [ 2437.500534] usb 1-1.4: Product: TP6920
    Jun 8 21:13:10 raspberrypi kernel: [ 2437.500546] usb 1-1.4: Manufacturer: TP6920
    Jun 8 21:13:10 raspberrypi kernel: [ 2437.500558] usb 1-1.4: SerialNumber: 0621
    Jun 8 21:13:10 raspberrypi kernel: [ 2437.504859] snd-usb-audio 1-1.4:1.0: cannot find the slot for index 0 (range 0-0), error: -16
    Jun 8 21:13:10 raspberrypi kernel: [ 2437.504882] usb 1-1.4: cannot create card instance 0
    Jun 8 21:13:10 raspberrypi kernel: [ 2437.504911] snd-usb-audio: probe of 1-1.4:1.0 failed with error -16
    Jun 8 21:13:10 raspberrypi systemd-udevd[1238]: failed to execute ‘/lib/udev/mtp-probe’ ‘mtp-probe /sys/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4 1 7’: No such file or directory

    looks like i probably messed up a config

    i followed a guide and changed

    options snd-usb-audio index=-2


    options snd-usb-audio index=0

  • Moderator

    Maybe. Sometimes it’s worth simply trying something before you start changing things. 🙂 More often than not it will work without modifying anything.

  • Project Sponsor Module Developer

    I reseted all my config changes

    the problem why I changed it was because I couldn’t record with arecord test.wav.
    So i thought the mic is not working, but it’s not the default mic. With arecord -D plughw:1,0 test.wav its’s working now. Thanks

    Any ideas how to change it to the default microphone?

  • Moderator

    Unfortunately, no. My recommendation is to find a raspberry forum, or search Google. Changing something to a default isn’t specific to that one microphone, it probably applies to many others. Might be an easy thing to fix.

Log in to reply