[Closed] Problem since update



  • Hello all,
    my first message for a trouble on the forum.

    Since i updated magicmirror to the new version 2.1 i’ve nothing on screen and from local browser (ssh connected)

    looking npm logs, i’ve this :

     node v7.6.0                                                                                  
    30 error npm  v3.10.10                                                                                
    31 error code ELIFECYCLE                                                                              
    32 error magicmirror@2.1.0 start: `electron js/electron.js`                                           
    32 error Exit status 1                                                                                
    33 error Failed at the magicmirror@2.1.0 start script 'electron js/electron.js'.                      
    33 error Make sure you have the latest version of node.js and npm installed.                          
    33 error If you do, this is most likely a problem with the magicmirror package,                       
    33 error not with npm itself.                                                                         
    33 error Tell the author that this fails on your system:                                              
    33 error     electron js/electron.js                                                                  
    33 error You can get information on how to open an issue for this project with:                       
    33 error     npm bugs magicmirror                                                                     
    33 error Or if that isn't available, you can get their info via:                                      
    33 error     npm owner ls magicmirror                                                                 
    33 error There is likely additional logging output above.                                             
    34 verbose exit [ 1, true ]         
    

    i added ipwhitelist like this :
    ipWhitelist: ["127.0.0.1", "::ffff:127.0.0.1", "::1", ["192.168.0.1", "192.168.0.100"]],

    could i have some help to find an issue to my problem ?


  • Core Contributors

    Try:

    DISPLAY=:0 nohup npm start
    


  • i’m added every modules one by one, testing after each one.

    I found twho differents modules (meteo) which were set at the same place. It seems to be the problem.



  • @roramirez what effects do i expect from your command ?


  • Core Contributors

    @Petal0u If you are connected by SSH this should work for you.

    Can you tell us what is your output with the command mentioned before?



  • no problem anymore because my sd card crashed.

    I’m reinstalling on a new card.

    I close the topic.

    Thanks for your help



  • @Petal0u there were a problem with config.js syntax :-)

    allways check config.js !!! :-D

    i close the discussion


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.