npm start dev doesn't work



  • When I try to run “npm start dev” or “DISPLAY=:0 npm start dev” I got an error tellming me that “start” doesn’t exist

    pi@raspberrypi:~ $ npm start dev
    pm ERR! missing script: start
    
    npm ERR! A complete log of this run can be found in:
    npm ERR!     /home/pi/.npm/_logs/2017-03-30T15_11_52_091Z-debug.log
    

    The log file mentioned in that message contain:

    pi@raspberrypi:~ $ cat /home/pi/.npm/_logs/2017-03-30T15_11_52_091Z-debug.log
    0 info it worked if it ends with ok
    1 verbose cli [ '/usr/bin/nodejs', '/usr/bin/npm', 'start', 'dev' ]
    2 info using npm@4.4.4
    3 info using node@v6.9.4
    4 verbose config Skipping project config: /home/pi/.npmrc. (matches userconfig)
    5 verbose stack Error: missing script: start
    5 verbose stack     at run (/usr/lib/node_modules/npm/lib/run-script.js:151:19)
    5 verbose stack     at /usr/lib/node_modules/npm/lib/run-script.js:61:5
    5 verbose stack     at /usr/lib/node_modules/npm/node_modules/read-package-json/read-json.js:356:5
    5 verbose stack     at checkBinReferences_ (/usr/lib/node_modules/npm/node_modules/read-package-json/read-json.js:320:45)
    5 verbose stack     at final (/usr/lib/node_modules/npm/node_modules/read-package-json/read-json.js:354:3)
    5 verbose stack     at then (/usr/lib/node_modules/npm/node_modules/read-package-json/read-json.js:124:5)
    5 verbose stack     at ReadFileContext. (/usr/lib/node_modules/npm/node_modules/read-package-json/read-json.js:295:20)
    5 verbose stack     at ReadFileContext.callback (/usr/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:78:16)
    5 verbose stack     at FSReqWrap.readFileAfterOpen [as oncomplete] (fs.js:365:13)
    6 verbose cwd /home/pi
    7 verbose Linux 4.4.21-v7+
    8 verbose argv "/usr/bin/nodejs" "/usr/bin/npm" "start" "dev"
    9 verbose node v6.9.4
    10 verbose npm  v4.4.4
    11 error missing script: start
    12 verbose exit [ 1, true ]
    
    

    How can I fix that issue ?


  • Module Developer

    @romain you have to get in to the magic mirror folder first before you can run npm start

    Ie type
    cd MagicMirror
    And then
    npm start

    Or
    display=:0 npm start
    If you are running it via ssh



  • Oh ! Thanks !! It work


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.