MM died after upgrade



  • Really new to MM and installed my first setup yesterday. Today it popped up a notification to upgrade it, so i did that according to the wiki and everything died :).

    npm log looks like this:

    0 info it worked if it ends with ok
    1 verbose cli [ '/usr/bin/nodejs', '/usr/bin/npm', 'start' ]
    2 info using npm@3.10.10
    3 info using node@v6.10.1
    4 verbose run-script [ 'prestart', 'start', 'poststart' ]
    5 info lifecycle magicmirror@2.1.1~prestart: magicmirror@2.1.1
    6 silly lifecycle magicmirror@2.1.1~prestart: no script for prestart, continuing
    7 info lifecycle magicmirror@2.1.1~start: magicmirror@2.1.1
    8 verbose lifecycle magicmirror@2.1.1~start: unsafe-perm in lifecycle true
    9 verbose lifecycle magicmirror@2.1.1~start: PATH: /usr/lib/node_modules/npm/bin/node-gyp-bin:/home/pi/MagicMirror/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games
    10 verbose lifecycle magicmirror@2.1.1~start: CWD: /home/pi/MagicMirror
    11 silly lifecycle magicmirror@2.1.1~start: Args: [ '-c', 'sh run-start.sh' ]
    12 silly lifecycle magicmirror@2.1.1~start: Returned: code: 1  signal: null
    13 info lifecycle magicmirror@2.1.1~start: Failed to exec start script
    14 verbose stack Error: magicmirror@2.1.1 start: `sh run-start.sh`
    14 verbose stack Exit status 1
    14 verbose stack     at EventEmitter. (/usr/lib/node_modules/npm/lib/utils/lifecycle.js:255:16)
    14 verbose stack     at emitTwo (events.js:106:13)
    14 verbose stack     at EventEmitter.emit (events.js:191:7)
    14 verbose stack     at ChildProcess. (/usr/lib/node_modules/npm/lib/utils/spawn.js:40:14)
    14 verbose stack     at emitTwo (events.js:106:13)
    14 verbose stack     at ChildProcess.emit (events.js:191:7)
    14 verbose stack     at maybeClose (internal/child_process.js:886:16)
    14 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
    15 verbose pkgid magicmirror@2.1.1
    16 verbose cwd /home/pi/MagicMirror
    17 error Linux 4.4.50-v7+
    18 error argv "/usr/bin/nodejs" "/usr/bin/npm" "start"
    19 error node v6.10.1
    20 error npm  v3.10.10
    21 error code ELIFECYCLE
    22 error magicmirror@2.1.1 start: `sh run-start.sh`
    22 error Exit status 1
    23 error Failed at the magicmirror@2.1.1 start script 'sh run-start.sh'.
    23 error Make sure you have the latest version of node.js and npm installed.
    23 error If you do, this is most likely a problem with the magicmirror package,
    23 error not with npm itself.
    23 error Tell the author that this fails on your system:
    23 error     sh run-start.sh
    23 error You can get information on how to open an issue for this project with:
    23 error     npm bugs magicmirror
    23 error Or if that isn't available, you can get their info via:
    23 error     npm owner ls magicmirror
    23 error There is likely additional logging output above.
    24 verbose exit [ 1, true ]
    

    Anyone that can give me any hints on fixing this, because right now I’m lost.



  • I upgraded and it’s not working either. I’m going to look into how to move back to the older version in the mean time :(

    edit: looks like I only used "pull’ and forgot to npm install… everything is working on my end now.



  • That did not help me.
    Tried to remove and uninstall and re setup and is now with this. Si I think i broke something :\

     DISPLAY=:0 npm start
    
    > magicmirror@2.1.1 start /home/pi/MagicMirror
    > sh run-start.sh
    
    App threw an error during load
    Error: Cannot find module '/home/pi/MagicMirror/js/../modules/default/defaultmodules.js'
        at Module._resolveFilename (module.js:470:15)
        at Function.Module._resolveFilename (/home/pi/MagicMirror/node_modules/electron/dist/resources/electron.asar/common/reset-search-paths.js:35:12)
        at Function.Module._load (module.js:418:25)
        at Module.require (module.js:498:17)
        at require (internal/module.js:20:19)
        at Object. (/home/pi/MagicMirror/js/app.js:11:22)
        at Object. (/home/pi/MagicMirror/js/app.js:243:3)
        at Module._compile (module.js:571:32)
        at Object.Module._extensions..js (module.js:580:10)
        at Module.load (module.js:488:32)
    A JavaScript error occurred in the main process
    Uncaught Exception:
    Error: Cannot find module '/home/pi/MagicMirror/js/../modules/default/defaultmodules.js'
        at Module._resolveFilename (module.js:470:15)
        at Function.Module._resolveFilename (/home/pi/MagicMirror/node_modules/electron/dist/resources/electron.asar/common/reset-search-paths.js:35:12)
        at Function.Module._load (module.js:418:25)
        at Module.require (module.js:498:17)
        at require (internal/module.js:20:19)
        at Object. (/home/pi/MagicMirror/js/app.js:11:22)
        at Object. (/home/pi/MagicMirror/js/app.js:243:3)
        at Module._compile (module.js:571:32)
        at Object.Module._extensions..js (module.js:580:10)
        at Module.load (module.js:488:32)
    


  • Gave up and did a git reset --hard, and that fixed it.


  • Module Developer

    I have had some issues as well, first i got the same file missing as @hajen, Copied it from my backup, got one step further and now it complained about the ical.js search path, it seems that not all files got updated in the default modules folder.

    I couldn’t get the git reset to work, so I downloaded the master file from git and just transfered the files directly to the pi. Now it works again.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.