MagicMirror² v2.7.0 is available! For more information about this release, check out this topic.

MMM-Transilien (Paris - France)



  • bonjour, j’ai un écran noir quand je lance le modules.

    voici mon code:

    modules: [
    {
    module: “MMM-Transilien”,
    position: “middle_center”,
    header:“Nemours vers Gare de Lyon”,
    config:{
    departUIC:“87684126”,
    arriveeUIC:“87686006”,
    login:“4d863c97-…”, // You must add your API login and password
    password:"…"
    }
    },
    ]

    pensez vous que les codes UIC ne sont pas bonne et qui me cause l’ecran noir ?

    en attente de vos reponse



  • @quisuisje bon j’ai trouvé le probleme d’ecran noir dans le dossier modules/MMM-Transilien/ faite un npm install
    pour le node.js
    ca marche impeccable!



  • Bonjour,
    J’ai le même problème que @quisuisje, mais par contre j’ai bien recompilé en lançant la commande “npm install”.
    Y’a t-il d’autres utilisateurs dans le même cas ?
    N’y a t-il pas eu des changements avec l’API Transilien ?

    Merci 😉



  • Rectif, je n’avais pas lancé la commande “npm install” dans le bon dossier…



  • Hello les gens

    nouveau sur le forum , je suis a la recherche de réponses .

    J’ai installé ce module avec quelques difficultés je dois bien l’admettre, et maintenant que mon miroir affiche l’info je suis a moitié soulagé. Pourquoi à moitié ? Parce que j’ai “Loading next train” d’affiché mais point d’horaires…qu’ai je loupé ? Une idée ?
    Pour info : api SNCF demandée et reçue c’est un grand chiffre ponctué de tirets et de chiffres et de lettres, rien mis dans password, UIC renseignés, j’ai même reçu un email de Transilien avec login et mdp que je n’ai pas utilisé puisque j’ai privilégié celui envoyé par SNCF…help…



  • Salut @G271IFCS,

    En regardant dans mon fichier de configuration (config.js), je vois que mon login est un code alphanumérique à 8 caractères (pas de tirets). J’ai aussi un password. Il doit donc y avoir un problème du côté de ton API login et du password associé.
    Pour être honnête, je ne me souviens plus comment je l’ai récupéré mais je pourrais le retrouver si tu ne t’en sors toujours pas.



  • Merci jeremy_fr, je teste ça et te tiens au courant…j’ai bien un login et pwd mais je ne l’ai pas utilisé , j’ai préféré employer la clé API envoyée par la SNCF alors que peut etre c’est l’identifiant et mdp du transilien que j’aurai dû mettre. (pour info c’est le RER qui m’interesse)



  • Bonsoir,

    essayé selon les conseils de jeremy_fr…sans succès, j’ai toujours ce message “loading next train”, je suis a bout d’idées…



  • ça maaaaarche ! (je ne sais pas pourquoi)



  • Tant mieux 🙂
    Pour aider la communauté, peux-tu confirmer que c’est bien suite à la correction des paramètres Login et password que le problème s’est corrigé ?
    Merci 🙂