No sound ober USB-Card



  • Hello,

    I can’t hear Sound over the USB-Card, only over HDMI.

    Only I make Speakertest , I can hear a noise.

    And I see it at alsamixer, but when I switch to USB Card at alsamixer and Close it and make a reopen , it’s the setting back to standard.



  • I’m quite new in Rpi and I had a loooooooooooooot of troubble with the sounds.

    I believe there is a way to desactivate HDMI audio somewhere in the sudo raspi-config and forcing the 3.5 m jack in the Advanced Options and Audio

    if that doesn’t work, I noticed that if you open alsamixer through a terminal, you can just change the value of the different channel but not “select” it as the default device to use.
    You can, however, open the “Audio Device Settings” in “Preferences” within the main menu of the pi on the desktop and choose the “default card” to use and reboot.

    Alternatively, you can creat a .asoundrc in your pi folder to describe what is the default card.(It will only concern the pi user though. You can make it globale if you use a /etc/asound.conf file instead). Those files probably doesn’t exist at first, you might have to create them.

    But at the end of the day, I never trully succeded to use my usb sound card fully. Not sure why but in a lot of circumstances the driver crash or something if I play a sound with it and all my usb devices directly plug in the pi freez. so I end up configure the asound.file to say that my output is the normal output of the pi and my microphone is the external sound card.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.