MM does not boot when starting my raspberry



  • I installed MM without problems. It works !
    But, MM does not boot when starting my raspberry.
    How to do ?

    Bisous
    Thx !



  • @asquelo You need to follow the following instruction: Auto Starting MagicMirror



  • I have installed AUTOSTART
    And I followed the instructions
    but it does not work



  • @asquelo You probably did it wrong. I did that a lot few weeks ago.
    you need to run pm2 startup as non sudo. then it display a command you have to run. On my pi it’s the following :

    pi@raspberrypi:~ $ pm2 startup
    [PM2] Init System found: systemd
    [PM2] You have to run this command as root. Execute the following command:
    sudo env PATH=$PATH:/usr/bin /usr/lib/node_modules/pm2/bin/pm2 startup systemd -u pi --hp /home/pi
    

    so you run the command that was display. For me it’s sudo env PATH=$PATH:/usr/bin /usr/lib/node_modules/pm2/bin/pm2 startup systemd -u pi --hp /home/pi

    Then you pm2 start mm.sh , then you wait until it’s open (not sure if it’s necessary to actually wait). Then while it’s open, you run pm2 save. They you can reboot and see your mirror open.

    I used to run sudo pm2 startup and don’t understand why it wasn’t working back in the day even though the autostart guide didn’t ask to do it…



  • 46/5000
    it works ! many thanks !



  • @romain I tried that and I have “env: /usr/lib/node_modules/pm2: Permission Denied” Do you know how to have access? Thanks.



  • @opensky727 did you put the sudo at the begining of the command ?
    It should loook like this
    sudo env PATH=$PATH:/usr/bin /usr/lib/node_modules/pm2/bin/pm2 startup systemd -u pi --hp /home/pi

    You should have the permission as sudo



  • @romain it worked, thanks a lot.



  • This worked for me thank you. There is a delay from when it boots up and MM starts, is there any way to reduce that time so the desktop never shows?



  • @RE_Magic_Mirror Not that I know of but I am not an expert in linux configuration.

    But if your issue is about “seeing” the desktop, I might have some tricks for you.
    Maybe you could change you desktop wallpaper to be a black screen for started and take away the trash icon so the desktop part is black and empty.
    Then you could right click on the panel barr above your screen and enter the panel settings and play around with them to make the barre itself invisible and then take away the unnecessary icons on it.
    It will not make your mirror start quicker but you won’t see the default wallpaper and menu as much


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.