Not again PIR



  • And again me ;). I can not see how my MagicMirror can work so far with my ignorance ok not really Ignorance but Noob, Noob, and for Luck I got Help from her e (THX Mykle1). But now I dont now what really happend, Ihave an PIR 501 and worked really fine with the Module MMM-PIR-Sensor. But now after I put all together in my Frame the Monitor goes off after 2 minuets but turns on b himself after ca. 30 seconds.That never happend befor I had it “free air”. Ok maybe its one or athe module wiche works not together. BTW. I am using a Raspbery PI 3. Edit the Monitor now doesnt turn off :(





  • @Damian Thank you, now I got me a Ferrit Bead but it still dont not work. Maybe my coding or my cabling is wrong.

    //		{
    		module: 'MMM-PIR-Sensor',
    		config: {
    			// See 'Configuration options' for more information.
    	sensorPIN: 22,
                                    powerSaving: true
                            }
                    },


  • Now that I deleted and reinstalled the module a new problem shows up . After I put the code In my config.js the Monitor stays black after the reboot. I testet the PIR its not broken.



  • Problem solved :)



  • @xeroxu

    How did you manage the fix what was wrong? thank you



  • @Damian I did after i checked the PIR a new npm install in the MM-PIR-Sensor Folder and changed the Sensor Pin to 25 (its the GPIO PIN) wrong thinking thats why I am a Noob ;)



  • @xeroxu said in Not again PIR:

    wrong thinking thats why I am a Noob

    Me too but i learn here by reading everything and try to understand better. thank you for reply it will help me too



  • @Damian no prob. im learning from reading and asking?



  • And again after two days the mirror did what he wants . I was nearly at that Point to throw all away and start fom beginning. Baut then i tried a thing , I disabled Bluetooth AND WLAN. And did it that way:

    //sudo nano /etc/modprobe.d/raspi-blacklist.conf
    
    blacklist brcmfmac
    blacklist brcmutil
    blacklist cfg80211
    blacklist rfkill
    blacklist btbcm
    blacklist hci_uart
    
    

    And after that a Reboot and

    //sudo systemctl disable hciuart
    

    and another reboot .

    This works, I hope longer then 2 Days ;)

    Now I have to work with the Ethernetport and gonna try it with an USB Wlan Dongle


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.