NPM process dies



  • Everything is working fine but I have a persistent issue that I can’t seem to fix. Whether I start NPM manually from a terminal or NPM starting automatically with a script, it seems to die randomly. The RPI3 is still up, just NPM dies. Are there logs that I take a look at to see what’s causing it?

    For the time being, I’m using crontab to reboot every couple of hours but I’d like to avoid that if possible.

    Thanks


  • Moderator

    If you install PM2 per the instructions, it will automatically get restarted if/when it dies.

    As for why it dies, if you are running PM2, you might be able to see if anything gets logged with 'pm2 logs'. But I’m not sure if it does log anything to be honest. PM2 does, but the npm process itself … unsure.



  • Thanks, this helps!


  • Moderator

    Are you using a proper power supply for the rpi? You need something that can provide at least 2A … anything less will cause it to be unstable with random crashes of processes. Adafruit has both a 2A version as well as a 2.4A one.



  • @KirAsh4 Yes, I bought the CanaKit 5V 2.5A Raspberry Pi 3 Power Supply


  • Moderator

    Other than a potential file system corruption, or faulty memory on the rpi itself, I can’t think of anything else that could be killing the process. While rather rare, I have seen brand new rpis have faulty memory. You’d have to install and run 'memtester' to check the memory. If that checks out, you can check the file system itself with 'fsck'. WARNING: doing this on a running system can cause issues. However, since the rpi runs off of the card, it’s unable to unmount the card, so you have two choices:

    a) schedule a file system check at the next reboot:

    $ sudo touch /forcefsck
    $ sudo reboot
    

    b) alternatively, you can force a file system check while it’s running:

    $ sudo fsck -fy /dev/mmcblk0p2 
    $ sudo reboot
    

    The 'mmcblk0p2' listed above you get by typing in 'mount' and looking at the line that shows the root file system on, denoted by a single '/':

    $ mount
    /dev/mmcblk0p2 on / type ext4 (rw,noatime,data=ordered)  


  • @KirAsh4 Thanks again. I ran memtester and everything was reported ok. I’m now going to use forcefsck and see what it finds.



  • @KirAsh4 Deployed PM2, and works as described. Thanks!


  • Moderator

    Glad that’s working. It still doesn’t solve the fact that it’s dying on you, but at least it will restart it automatically for you. I think my process dies at least once a week or so … totally random, with the pi doing nothing.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.