MMM-MyCalendar



  • @j-e-f-f said in MMM-MyCalendar:

    @Fonfon No, but you can add a background colour to the module to make the text stand out better. try something like this in your custom.css file:

    .MMM-MyCalendar .module-content {
      background-color: rgba(0,0,0,0.5);
    }
    

    The first three parameters 0,0,0 mean black, and the fourth parameter 0.5 is the level of transparency. Specify a decimal between 0 and 1, where 0 is fully transparent, and 1 is fully opaque.

    Thanks j.e.f.f for your help !



  • @zzaidi148 @j-e-f-f

    I have this same issue and haven’t had any luck in resolving the issue. I even copied the recommended config from earlier in this forum. Is there something that I am missing?

    It will just say, “Loading…”

    0_1558248904989_MMMirror.PNG

    {
    			module: "MMM-MyCalendar",
    			position: "top_left",
    			classes: "default everyone",
    			header: "Upcoming",
    			disabled: false,
    			config: {
    				colored: true,
    				maximumNumberOfDays: 30,
    				maximumEntries: 5,
    				fade: false,
    				maxTitleLength: 500,
    				useRelativeDates: false,
    				dayOfWeekFormat: "dddd",
    				timeFormat: "h:mm A",
    				dateFormat: "MMMM D",
    				joiningWord: "at",
    				urgency: 1,
    				calendars: [
              {
    					url: "https://calendar.google.com/calendar/ical path",
    					color: "#ffb350"
              },
              {
    					url: "https://calendar.google.com/calendar/ical path",
    					color: "#ff77d4"
              }
            ]
          }
        }
    


  • @charp07 figured it out! Sorry!



  • @j-e-f-f This feature (grouping by day) would be awesome! Have you had a chance to make any progress on this?



  • Did anybody’s MMM-MyCalendar module break after daylight savings (Sunday November 3rd)? Both my “MMM-MyCalendar” AND “MMM-CalendarExt2” modules are showing events on the wrong days now. The problem seems to only occur with reoccurring events; they usually show up one day earlier. Rebooting does not correct the issue. I hope someone can figure this out soon 😞