Raspberry Pi 1 - Any Magic Mirror Setup Possible?



  • Hi All,

    I’m just curious as to whether the raspberry pi 1 is still at all possible to run the magic mirror stuff. I came across conflicting information online - hit the fact that chromium no longer is supported for the first raspberry pi. Came across the magic mirror ^2 thread that said something about running a server on the Pi (without clear instructions) that suggested it might still be possible but without Chromium I wasn’t sure whether this is now out of date.

    Basically I have a spare one and just want to put it to an interesting use. If it’s still possible I’ll document my efforts and try to get some decent instructions together.

    Thanks


  • Module Developer

    You can execute the server by navigating to the MM folder (after you’ve cloned it) and executing node server only on the command line.

    Then you would need to navigate using a browser to your localhost address (i.e http://127.0.0.1) where you would see the app.

    You can think of the electron application as a browser in a window (the bit that relies on chromium) - But if you can’t use that, you can always just navigate to the address yourself. Setting up borderless windows and stuff is something you can do manually elsewhere. There’s more information on how to rotate the display and do all the borderless windows stuff on this blog



  • Yep, it’s definitely possible, but it’s not easy. I’ve got the server plus an auto-boot into chromium kiosk mode up and running on a Raspberry Pi 1.

    Here’s some half-written notes that I was keeping as I went through the process. Hopefully somebody can take this and turn it into better documentation.

    PC-side:
    install WinSCP: https://winscp.net/eng/download.php
    install PuTTY: http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

    Overall kiosk screen setup:
    See https://www.danpurdy.co.uk/web-development/raspberry-pi-kiosk-screen-tutorial/
    Important commands:

    sudo apt-get update && sudo apt-get upgrade -y
    sudo apt-get install chromium x11-xserver-utils unclutter
    

    Install node.js:
    See https://www.losant.com/blog/how-to-install-nodejs-on-raspberry-pi
    Important commands:

    curl -o- https://raw.githubusercontent.com/creationix/nvm/v0.31.0/install.sh | bash
    nvm install v6.2.1
    

    Magic Mirror setup:
    See https://github.com/MichMich/MagicMirror#usage
    Important commands:

    sudo apt-get install php5
    curl -sL https://raw.githubusercontent.com/MichMich/MagicMirror/master/installers/raspberry.sh
    (need to modify raspberry.sh to take out the Pi1 fail check)
    bash raspberry.sh
    git clone https://github.com/MichMich/MagicMirror
    cd ~/MagicMirror
    npm install
    node serveronly
    

    Raspberry Pi 1 CSS incompatibility issue
    fix drawing:
    nano css/custom.css

    	height: 90%;
    	width: 90%;
    

    (TODO - find better fix for this)

    Install wifi adapter:
    See https://www.raspberrypi.org/forums/viewtopic.php?p=462982#p462982
    Important commands:

    lsusb
    uname -a
    wget https://dl.dropboxusercontent.com/u/80256631/8188eu-20160305.tar.gz
    tar xzf 8188eu-20160305.tar.gz
    ./install.sh
    sudo reboot
    

    Create a startup script:

    nano run_magicmirror.sh
    
    echo 'removing log.txt'
    rm -f /home/pi/MagicMirror/log.txt
    
    echo 'running MagicMirror server'
    /home/pi/.nvm/versions/node/v6.2.1/bin/node /home/pi/MagicMirror/serveronly > /home/pi/MagicMirror/log.txt
    
    echo 'waiting for server to start'
    sleep 20
    
    echo 'running web browser'
    chromium --noerrdialogs --kiosk --incognito http://localhost:8080
    

    Set up autostart:
    See https://github.com/MichMich/MagicMirror/wiki/Configuring-the-Raspberry-Pi
    Important commands:
    sudo nano /etc/xdg/lxsession/LXDE/autostart

    	@xscreensaver -no-splash
    	@xset s off
    	@xset -dpms
    	@xset s noblank
    	@lxterminal -e sh /home/pi/run_magicmirror.sh
    

    Note from admin: Please use Markdown on code snippets!



  • Hello @mbalfour I tried in every way to install the software but have not been able, I fail dependencies and much more.

    You could upload an OS image of your magic mirror? if you can not, I’ll have to abandon the project because I am not able to install the software on my pi1



  • Hi All,
    Thanks for the replies! I’ve gotten ridiculous busy in real world stuff but the goal is to try this out in 3 weeks. I’ll post my results



  • @sagatxxx I’m not in a state where I can upload a full OS image, but if you explain more fully what steps you’ve tried and where you’re failing, I can try and provide a bit of guidance.



  • @mbalfour thanks a lot

    I will follow your guide and I will be showing the problems I find:
    The first is that when I try to install the chromium browser:

    sudo apt-get install chromium x11-xserver-utils unclutter
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Package chromium is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    However the following packages replace it:
      chromium-inspector chromium-bsu
    
    E: Package 'chromium' has no installation candidate
    


  • @sagatxxx Chromium has been deprecated from the repository. This may be useful: http://raspberrypi.stackexchange.com/questions/41603/installing-chrome-on-raspbian



  • @jmadero said in Raspberry Pi 1 - Any Magic Mirror Setup Possible?:

    @sagatxxx Chromium has been deprecated from the repository. This may be useful: http://raspberrypi.stackexchange.com/questions/41603/installing-chrome-on-raspbian

    hi

    I followed this steps:

    wget https://dl.dropboxusercontent.com/u/87113035/chromium-browser-l10n_45.0.2454.85-0ubuntu0.15.04.1.1181_all.deb
    wget https://dl.dropboxusercontent.com/u/87113035/chromium-browser_45.0.2454.85-0ubuntu0.15.04.1.1181_armhf.deb
    wget https://dl.dropboxusercontent.com/u/87113035/chromium-codecs-ffmpeg-extra_45.0.2454.85-0ubuntu0.15.04.1.1181_armhf.deb
    sudo dpkg -i chromium-codecs-ffmpeg-extra_45.0.2454.85-0ubuntu0.15.04.1.1181_armhf.deb
    sudo dpkg -i chromium-browser-l10n_45.0.2454.85-0ubuntu0.15.04.1.1181_all.deb chromium-browser_45.0.2454.85-0ubuntu0.15.04.1.1181_armhf.deb
    

    finally chromium browser seems to install correctly but when open it does not work and is not displayed



  • Hm, the post that @jmadero links to is from Jan, but I installed Chromium just a few weeks ago successfully. Did you run this first before trying to install chromium?

    sudo apt-get update && sudo apt-get upgrade -y
    

    This step is necessary for making sure you’ve got the latest repository lists, I think.

    Also, when you open the chromium browser that you did install, what exactly happens? Does the browser itself not work, or are you not seeing the MagicMirror page? Once again, please be specific!


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.