Magic Mirror on the Raspberry Pi 1, agonizingly difficult



  • First if all, I’m new to linux and the pi, so please forgive my ignorance.
    Anyway, I’ve been trying to get the magic mirror to work on my old Pi 1 for some time now, but can’t for the life of me figure out how to do it.
    I’ve followed all the instructions that I’ve come across, but still can’t figure it out.
    I understand the Pi 1 is not supported so needs to be run in serveronly mode which I cannot get to work.
    I’ve installed node.js and npm (I think) but can’t get it to work. (To say I have no idea what I’m doing is an understatement.)
    (I did try to comment out the bit of the installer that checks the RPi version and the installer did run [after executing bash raspberry.sh] but said it was unable to install dependencies.)

    Specs:
    Raspberry Pi 1
    node.js - version 5.1.0
    npm - version 3.3.12
    docker - version 1.3.3

    Any help would be greatly appreciated.
    P.S. Sorry for the long post and thank you in advance
    (By the way, I have looked at the other posts regarding the Pi1 but none of the information there helped, I really am clueless)



  • It may be best to let us know what errors you are getting or problems are you are encountering. Are you able to run servermode or are you not getting that far?



  • Thanks for the quick reply.
    I’ve tried to run node serveronly in the terminal, but as far as I understand, I haven’t been able to get it to work.
    Howeve, when I go to http://localhost in Chromium (where I assume the MM would be when it works) it do get a message mentioning ngix and saying the debian web server is up and running, though the serveronly mode doesn’t seem to be working.



  • It would be http://localhost:8080



  • It says that the site can’t be reached and that localhost refused to connect


  • Module Developer

    @MMRPi1 What kind of messages are shown when you run node serveronly in the shell?




  • Module Developer

    You need express.js
    I guess your auto-installation process didn’t work anyhow. You can try manual installation. (And I recommend that.)
    See this.



  • @Sean I’ve tried following the instructions on that page but it hasn’t worked.
    How do I install express.js?


  • Module Developer

    @MMRPi1 hmmm…

    1. Go to your MagicMirror directory.
    2. Is there package.json file in your MagicMirror directory? (..../MagicMirror/package.json)
    3. If there is, open package.json you can see like this.
    ...
      "dependencies": {
        "body-parser": "^1.17.1",
        "colors": "^1.1.2",
        "electron": "^1.4.7",
        "express": "^4.14.0",
        "express-ipfilter": "latest",
        "feedme": "latest",
     ...
      }
    }
    
    1. Then, you can run npm install in /MagicMirror directory.
    2. See how it goes.


Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.