MMM-Remote-Control - Disable auto monitor off



  • Hi!

    Whenever I activate the wonderful MMM-Remote-Control and either start or refresh my mirror, I have to manually use the remote-control to turn on my monitor again.

    Is there any way to disable this auto turn off HDMI feature?

    Cheers from Denmark!


  • Module Developer

    @Skanderup are you using raspbian desktop? Check xset dpms setting. I think xset dpms off And xset dpms 0 0 0 Will work.



  • @Sean
    Hi Sean

    It’s the Remote-Control module that automatically disables the HDMI. If I don’t enable the remote-control module in my config.js, the screen stays on as it should.


  • Module Developer

    @Skanderup I’m not using this module, so I read code now. It seems using tvservice. So what is your problem? Whenever you include this module, the monitor is powered off from beginning so you should turn it on by yourself with this module?
    Or whenever you use this module, the screen power-save mode is on automatically not as your intend? More detailed info is needed.
    So, describe what you might expect and what you get really, which condition you had please.



  • @Sean

    Thank you for helping Sean.

    The problem is that when the remote-control module is loaded by MagicMirror somewhere in the code it says disable HDMI. So whenever my screen powers up and loads the magicmirror everything works fine until the remote-control module is loaded, then my monitor goes from showing the magicmirror to “searching for input source”.

    What I want the remote module to do is just be enabled in the background without disabling the rpi HDMI automatically from the beginning.

    Makes sense? :)


  • Module Developer

    @Skanderup It looks so weird. I cannot find any suspicious thing on git codes. There seems no point to control hdmi except tvservice but I’ve never heard that could make this kind of issue.
    Hmmmm. Maybe I can install this module by myself and examine. But today is an holiday so I can try next Monday. I wish you could find solution before then. Good luck!
    (You’d better ask the module developer on github directly.)


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.