Installation Error



  • Hey guys,

    tried to install MM² on two different RPi3.

    Tried up this Installations:
    _Arch OS
    _Raspbian Jessie Light
    _Raspbian Jessie

    On Arch i was abtle to install everything needed. On Raspbian Jessie Light and Jessie i was able to use the install script. On all three setups i got the same debug message:

    0 info it worked if it ends with ok
    1 verbose cli [ ‘/usr/bin/nodejs’, ‘/usr/bin/npm’, ‘start’, ‘debug’ ]
    2 info using npm@3.8.6
    3 info using node@v5.12.0
    4 verbose run-script [ ‘prestart’, ‘start’, ‘poststart’ ]
    5 info lifecycle magicmirror@2.0.0~prestart: magicmirror@2.0.0
    6 silly lifecycle magicmirror@2.0.0~prestart: no script for prestart, continuing
    7 info lifecycle magicmirror@2.0.0~start: magicmirror@2.0.0
    8 verbose lifecycle magicmirror@2.0.0~start: unsafe-perm in lifecycle true
    9 verbose lifecycle magicmirror@2.0.0~start: PATH: /usr/lib/node_modules/npm/bin/node-gyp-bin:/home/pi/MagicMirror/node_modules/.bin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games
    10 verbose lifecycle magicmirror@2.0.0~start: CWD: /home/pi/MagicMirror
    11 silly lifecycle magicmirror@2.0.0~start: Args: [ ‘-c’, ‘electron js/electron.js “debug”’ ]
    12 silly lifecycle magicmirror@2.0.0~start: Returned: code: 1 signal: null
    13 info lifecycle magicmirror@2.0.0~start: Failed to exec start script
    14 verbose stack Error: magicmirror@2.0.0 start: electron js/electron.js "debug"
    14 verbose stack Exit status 1
    14 verbose stack at EventEmitter. (/usr/lib/node_modules/npm/lib/utils/lifecycle.js:239:16)
    14 verbose stack at emitTwo (events.js:100:13)
    14 verbose stack at EventEmitter.emit (events.js:185:7)
    14 verbose stack at ChildProcess. (/usr/lib/node_modules/npm/lib/utils/spawn.js:24:14)
    14 verbose stack at emitTwo (events.js:100:13)
    14 verbose stack at ChildProcess.emit (events.js:185:7)
    14 verbose stack at maybeClose (internal/child_process.js:850:16)
    14 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:215:5)
    15 verbose pkgid magicmirror@2.0.0
    16 verbose cwd /home/pi/MagicMirror
    17 error Linux 4.4.16-v7+
    18 error argv “/usr/bin/nodejs” “/usr/bin/npm” “start” "debug"
    19 error node v5.12.0
    20 error npm v3.8.6
    21 error code ELIFECYCLE
    22 error magicmirror@2.0.0 start: electron js/electron.js "debug"
    22 error Exit status 1
    23 error Failed at the magicmirror@2.0.0 start script ‘electron js/electron.js “debug”’.
    23 error Make sure you have the latest version of node.js and npm installed.
    23 error If you do, this is most likely a problem with the magicmirror package,
    23 error not with npm itself.
    23 error Tell the author that this fails on your system:
    23 error electron js/electron.js "debug"
    23 error You can get information on how to open an issue for this project with:
    23 error npm bugs magicmirror
    23 error Or if that isn’t available, you can get their info via:
    23 error npm owner ls magicmirror
    23 error There is likely additional logging output above.
    24 verbose exit [ 1, true ]

    When i “startx” and use the lxterminal to start MM² everything works fine. But i cant get it work on autostart?

    Isnt there any leight OS installation version for MM? I dont want to use the full jessie installation (loved to use arch instead of raspbian)


  • Moderator


  • Moderator

    As an FYI, you must have Xwindows and a window manager running for MagicMirror² to work. It uses Electron as a browser, which needs the graphical interface on the rpi to already be up and running. By itself, MagicMirror² does nothing with the OS. The end-user is responsible to make sure everything is setup properly and correctly.

    The fact that you have to manually run 'startx' tells me you have the graphical environment installed, but you aren’t loading it automatically after the rpi boots up. You need to fix that. However you do it, that is outside the scope of MagicMirror.

    Having played with this myself, one can run Jessie-light, however you need to then manually install all of the related packages to get the graphical environment up and running. You’re better off running the standard Jessie release and just cleaning off things that aren’t going to be used. That is extensively covered in the full tutorial I linked in my previous reply.



  • thank you very much :) so i have another try to use arch linux than :) just install lxde light and autostart it should fix my problems. thought the script will install/check if all requirements (like x11/lxde) are installed


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.