MMM-Remote-Control-Repository


  • Module Developer

    MMM-Remote-Control-Repository

    This module automatically updates modules.json of MMM-Remote-Control with information of https://github.com/MichMich/MagicMirror/wiki/MagicMirror²-Modules

    As you know, MMM-Remote-Control is a great module, I think it is essentially needed to manage your MagicMirror. But installable modules are limited by modules.json. And it was managed by manual. The last update was 7 months ago.

    After conversation with @Jopyth in Slack, I thought it could be a good option to provide automatically updated modules.json

    https://github.com/MichMich/MagicMirror/wiki/MagicMirror%C2%B2-Modules would be working as a deFacto repository for MagicMirror modules. So installable modules data was derived from there.

    Download:



  • Hi,

    I have a little problem with your module. I hae install correctly and my MagicMirror starts. Now I have start with npm start dev because of an other problem. And I found two errors atr the console.

    Failed to load resource: the server responded with a status of 404 (Not Found)
    Error on loading script: modules/MMM-Remote-Control-Repository//MMM-Remote-Control-Repository.js

    and

    Failed to load resource: the server responded with a status of 404 (Not Found)
    Error on loading script: modules/MMM-Remote-Control-Repository//MMM-Remote-Control-Repository.js

    Can you help me?

    greets gismo


  • Module Developer

    @gismo2006
    The message means MMM-Remote-Control-Repository was not installed properly.
    Check if the source is located in proper position.

    cd {your magicmirror directory}/modules/MMM-Remote-Control-Repository
    ls
    

    Are the directory and files located properly?



  • Hi,

    ok I found the problem. I have install like you write, but the module folder wasn´t called MMM-Remote-Control-Repository the created folder was named RC-Repository. I have changed the name and now there are no errors shown.

    Thank you


  • Module Developer

    @gismo2006
    Sorry. That was my typo miss. I fix it now.


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.