MMM-stib does not display, but data is on the start screen.



  • Re: STIB Brussels Transport Waiting time at stops

    MMM-stib does not display, but data is on the terminal screen: I start MM from a terminal and it display correctly the modules, but without stib data. Howerver, after aborting, the terminal show this, with block “STIB this.lines” repeated many times :

    Please tell if another info is necessary to document my problem !

    What am I missing ?

    pi@raspberrypi3:~/MagicMirror $ npm start

    magicmirror@2.1.3 start /home/pi/MagicMirror
    sh run-start.sh

    Starting MagicMirror: v2.1.3
    Loading config …
    Loading module helpers …
    No helper found for module: alert.
    Initializing new module helper …
    Module helper loaded: updatenotification
    No helper found for module: clock.
    Initializing new module helper …
    Module helper loaded: calendar
    No helper found for module: compliments.
    No helper found for module: currentweather.
    No helper found for module: weatherforecast.
    Initializing new module helper …
    Module helper loaded: newsfeed
    Initializing new module helper …
    Module helper loaded: stib
    All module helpers loaded.
    Starting server on port 8080 …
    Server started …
    Connecting socket for: updatenotification
    Connecting socket for: calendar
    Starting node helper for: calendar
    Connecting socket for: newsfeed
    Starting module: newsfeed
    Connecting socket for: stib
    Starting node helper for: stib
    Sockets connected & modules started …
    Launching application.
    Create new calendar fetcher for url: http://www.calendarlabs.com/templates/ical/US-Holidays.ics - Interval: 300000
    Create new news fetcher for url: http://www.nytimes.com/services/xml/rss/nyt/HomePage.xml - Interval: 300000
    Create new waiting time fetcher for url: http://m.stib.be/api/getwaitingtimes.php?halt=5802 - Interval: 60000
    Create new waiting time fetcher for url: http://m.stib.be/api/getwaitingtimes.php?halt=5714 - Interval: 60000
    STIB this.lines {“stopname”:[“TILLEUL”],“position”:[{“latitude”:[“50.87593”],“longitude”:[“4.39285”]}],“waitingtime”:[{“line”:[“55”],“mode”:[“T”],“minutes”:[“1”],“destination”:[“ROGIER”],“message”:[""]},{“line”:[“55”],“mode”:[“T”],“minutes”:[“5”],“destination”:[“ROGIER”],“message”:[""]}]}
    STIB node helper {“stopname”:[“TILLEUL”],“position”:[{“latitude”:[“50.87593”],“longitude”:[“4.39285”]}],“waitingtime”:[{“line”:[“55”],“mode”:[“T”],“minutes”:[“1”],“destination”:[“ROGIER”],“message”:[""]},{“line”:[“55”],“mode”:[“T”],“minutes”:[“5”],“destination”:[“ROGIER”],“message”:[""]}]}

    EDIT:
    After a good night and some search, if found this site [https://forum.magicmirror.builders/topic/151/stib-brussels-transport-waiting-time-at-stops/3](link url)
    and it solve my problem.

    Thanks for reading !


Log in to reply
 

Looks like your connection to MagicMirror Forum was lost, please wait while we try to reconnect.