MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

Calender module shows the wrong local time



  • I am using the default calendar module, and have adjusted it to my country (Singapore). However the dates are correct but the time is wrong (instead of 15:00, it shows 19:00) it seems to be still on US time, any way to change the time under the calendar module or to switch it off ?



  • You have to set the time in the system, the mirror (and with it the modules) gets the time from there.
    Are you using a Raspberry Pi? Go to settings or enter sudo raspi-config in the console and check if the time zone is correct.



  • My PI time setting is correct, and it shows the correct time in the time module at the MagicMirror as well. Its only the calendar module that shows the incorrect time hence I have two different times shown on the MM.



  • Might be the calendar’s settings, then. Google calendar?



  • Oh man, I think the mystery is solved !
    Its not actually the present time, its probably the time of the sunset :-0
    sorry for the confusion, but I am still releaved to have one problem less !!!
    Thanks for your support and suggestions which led me to the right conclusion.