MagicMirror² v2.4.1 is available! For more information about this release, check out this topic.
Please read the release notes carefully since this update requires adjustments to your Raspberry Pi configuration!

Npm start issues



  • Errors after i try to run npm start in the terminal. I can’t figure out what to do from here?



  • have a screenshot of the errors? or just copy/paste the error messages.

    Where did u type npm start? u need to be in the MagicMirror Folder.



  • pi@raspberrypi:~/MagicMirror $ npm start

    magicmirror@2.1.3 start /home/pi/MagicMirror
    sh run-start.sh

    run-start.sh: 4: run-start.sh: electron: not found

    npm ERR! magicmirror@2.1.3 start: sh run-start.sh
    npm ERR! Exit status 127
    npm ERR!
    npm ERR! Failed at the magicmirror@2.1.3 start script.
    npm ERR! This is most likely a problem with the magicmirror package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR! sh run-start.sh
    npm ERR! You can get their info via:
    npm ERR! npm owner ls magicmirror
    npm ERR! There is likely additional logging output above.
    npm ERR! System Linux 4.9.59-v7+
    npm ERR! command “/usr/bin/nodejs” “/usr/bin/npm” "start"
    npm ERR! cwd /home/pi/MagicMirror
    npm ERR! node -v v4.8.2
    npm ERR! npm -v 1.4.21
    npm ERR! code ELIFECYCLE
    npm WARN This failure might be due to the use of legacy binary "node"
    npm WARN For further explanations, please read
    /usr/share/doc/nodejs/README.Debian

    npm ERR!
    npm ERR! Additional logging details can be found in:
    npm ERR! /home/pi/MagicMirror/npm-debug.log
    npm ERR! not ok code 0



  • did you run npm install first? or did u use the automatic installer? Looks like there is no electron installed.
    maybe try to execute “DISPLAY=:0 nohup npm start &”

    But i need to say that i am no developer or programer or something like that. Just started to try understanding the whole stuff ^^
    So keep that i mind and before u crash something maybe u should wait for someone who got more ideas.

    for so long keep reading: https://www.google.de/search?client=safari&rls=en&q=run-start.sh:+4:+run-start.sh:+electron:+not+found&ie=UTF-8&oe=UTF-8&gfe_rd=cr&dcr=0&ei=Q9JDWuagJ6zBXqmvrKAI



  • I’m just starting out too, that’s why I’m having problems. Lol



  • hmm. which os did u use? is it a fresh install?
    I’m using stretch lite, but that needs more steps to install the MM.

    So i recommend to use a desktop version (with pixel) for the first.
    If u did, i would use this guide: https://forum.magicmirror.builders/topic/236/complete-setup-tutorial

    Or, if u would like to use a lite OS Version i would use this: https://github.com/MichMich/MagicMirror/wiki/Jessie-Lite-Installation-Guide

    Last one worked fine for me. It takes about 30-60 Minutes all in all to set up the Magic Mirror when i did it first time. Important is to read carefully and take the time u need for it 😉



  • I used automatic installer. And the OS was the lite system that came with my raspberry



  • I tried your first suggestion and this is what happened.

    pi@raspberrypi:~/MagicMirror $ DISPLAY=:0 nohup npm start &
    [1] 1854
    pi@raspberrypi:~/MagicMirror $ #nohup: ignoring input and appending output to 'nohup.out



  • that should be the reason, why u are running in trouble. With the lite version there are missing some packages, which u have to install manually.

    i would delete the MagicMirror folder with “rmdir MagicMirror” and try to set it up again with using the second link i posted above.

    Even better if u install a whole new OS on your SD-Card, 'cause i don’t know what stuff is installed there.



  • It said failed to remove magic mirror